The most weird thing is happening to me: I have a hp notebook which has no internal DVD drive, so I installed via an external USB LG Blueray burner.

  1. First I installed Windows 10 customer preview into one partition.
  2. Then I installed Windows 8 into another partition.

All works fine. I have dual boot computer where I can test my software on Windows 8 and 10.

The computer has the following partitions:

  1. Recovery partition (300 MB)
  2. EFI System partition (100 MB)
  3. Data partition (400 GB)
  4. Windows 8 (40 GB)
  5. Window 10 preview (40 GB)

I repeat: All works fine. Neither the installation of Windows 8 nor 10 preview produced any problem.

Now comes the most weird thing that I have seen: As the final Windows 10 is out now, I wanted to replace the Windows 10 preview with the final Windows 10.

I boot the installation DVD, after a while comes the screen where I can select the language. Then comes a screen with a button in the center that says "Install Now" and then comes a message "Setup is starting".

Up to here all fine. But then comes a strange error:

A media driver your computer needs is missing. This could be a DVD,USB or hard disk driver. If you have CD, DVD or USB flash drive on it, please insert it now.

Note: If the installation media for Windows is in the DVD drive or on a USB drive, you can safely remove it for this step.

First: this error is not understandable. Second: It does not make any sense. When setup was already running up to here this means that it CAN read the DVD. So what driver should be missing?

Some people reported similar problems with Windows 7 where the cause was that it did not boot from a USB 3.0 port. But this cannot be the culprit because

  1. Windows 10 does not have this limitation anymore.
  2. I tried all the 3 existing USB ports and all result in the same error.
  3. I installed the Windows 10 preview with the same Blueray burner on the same notebook. Why does the preview find the driver and the final not?

I came to the conclusion that this is -once more- a wrong error message. The cause must be elsewhere.

Then I made a very interesting test:

I booted from the same Windows 10 preview DVD that I installed a month ago. And voilá: It also does not boot anymore. But it gives another error:

On a black screen it tells me

CDBOOT: Couldn't find BOOTMGR

Missing OS

No bootable device -- insert boot disk and press any key.

How is it possible that the SAME DVD, that I installed successfully one month ago, now throws an error ?

Then I made a third test: I booted from the same Windows 8 DVD that I installed before. And this is the only DVD of the 3 DVDs where I get up to the menu which allows me to select the parition into which I want to install.


  1. Win 10 final DVD fails with one error
  2. Win 10 preview DVD fails with another error, although it worked before!
  3. Win 8 DVD runs correctly

It is clear that this is

  1. Not a hardware problem: same notebook, same blueray burner, both Windows still run perfectly.
  2. No driver is missing because both Windows were installed without problems before.
  3. The DVDs are not burned wrongly, they worked before.

For me the only explanation is that the installation of Windows 8, which I installed after Windows 10 preview, destroyed anything on that computer.

Nevertheless both OS still run without problem, it is only the installation which is blocked.

But what has happened? Are there any diagnose tools? Has anybody seen such a strange thing before? Does anybody know a workaround (except deleting all partitions and starting from zero)?

  • Yes. But I prefer strongly to have the installation DVD in my hands. Because some day Microsoft will not offer this update anymore. And may be I want to install the same Windows 10 on another computer without waiting hours for a download to complete.
    – Elmue
    Commented Aug 29, 2015 at 0:08
  • It seems you did not understand me. If I want to install a new Windows 10 on another computer with an empty harddisk I will need an ISO image. There is no update possible if the disk is empty with no previous Windows version installed. How will Windows be activated automatically? Is the activation data stored in the BIOS?
    – Elmue
    Commented Oct 20, 2015 at 11:09
  • a simple recovery drive will throw that error, you need to get the complete installation file using Windows 10 Creators.
    – JinSnow
    Commented Aug 28, 2017 at 13:58
  • None of the answers worked for me. But actually going to motherboard website, downloading Chipset-IDE drivers, putting them on the USB drive and browsing/selecting them helped me to fix this. Sometimes you need to actually do what the message says.
    – Mardari
    Commented Apr 5, 2023 at 9:43

7 Answers 7


Finally I solved the problem.

The cause of the error "A media driver your computer needs is missing" may be that the ISO image is corrupt. I did not expect that because I downloaded the entire 4 GB image directly from Microsoft without any error from https://www.microsoft.com/en-us/software-download/windows10ISO

As Microsoft does not provide a hash you cannot verify the downloaded file.

After downloading the image from another place: https://www.microsoft.com/en-us/software-download/techbench it worked.

ADDITION: Now I use a newer version of Firefox (43) which always shows an error if the download (first link above) was not successful. The Microsoft link for ISO download is garbage. I tried several times to download the ISO file (4 GB) and Firefox told me once that 13 MB were missing and the next time that 430 MB were missing. The Microsoft Server aborts the transmission shortly before you have downloaded the ISO file completely. So you MUST use the Media creation tool to download Windows 10! This tool requires at least Windows 7. Forget it to download Windows 10 with any other operating system than Windows 7 or 8. It is really a SHAME that Microsoft is not able to provide a download of an ISO file!

Another solution may be to copy the Windows ISO to an USB stick when you get this error message. You can use Rufus for that. It may solve this error in the case that the cause is a problem with your DVD/Blueray drive. Not all drives support UEFI.

  • 1
    The entire .ISO can be downloaded by using the Media Creation Tool which also can make a unified x86/x64 .ISO if you want it.
    – Ramhound
    Commented Aug 28, 2015 at 23:40
  • 5
    I got the exactly same problem. I download the ISO from Microsoft using chrome, no error returns. I could successfully mount the ISO and burn the ISO into USB. However, it keeps complaining driver error. I tried to reformat the harddisk, refomat the USB and re-burn the ISO, all no luck. Eventually, I found that the download is actually not complete! Chrome just did not report the error. It's easy to check actually, just try to trigger download using wget, and have a look of total size in bytes, and verify it against yours. Commented Dec 12, 2015 at 1:02
  • 3
    This is completely infuriating. I don't have a windows computer so I am stuck using dd to write the image to usb. The md5 I have for the image (Win10_1511_1_English_x64.iso) is a4fde74732557d75ffc5354d0271832e which appears to be valid. I have downloaded it with Firefox and Chrome and both times it comes back with the same md5 checksum. Commented Apr 30, 2016 at 15:04
  • 2
    Hello. Thank you very much, this solved my problem. After one week trying everything, today I could install W10 by creating a disk with the Media Creation Tool and using Rufus to put it in a flash disk. Downloading the ISO directly from Microsoft website doesn't work as you described (I tried many ISOs). Also, these did not work: (a) Changing usb ports during installation; (b) saving the SATA driver in the USB and loading it during installation; (c) start the computer with the SATA driver disconnected and connecting it during installation; (d) formatting the ssd with diskpart.
    – computeiro
    Commented Sep 17, 2017 at 23:30
  • 1
    I wanted to point out that I also solved this by using modern.ie VM to get a working windows, and then using MCT to download the ISO and Rufus to create a bootable usb drive. (explanation here: stackoverflow.com/questions/55982852/…)
    – Helios
    Commented May 4, 2019 at 13:09

In my case, the A media driver your computer needs is missing error was caused by incorrectly flashed .iso image on the USB flash drive.

The incorrectly flashed image, which booted just fine but later gave the error showed up as a single line in the boot menu, looking like this:

enter image description here

While the correctly flashed image showed up as two separate partitions, looking like this:

enter image description here

The image was incorrectly flashed using Linux Mint 19, with both the default USB Image Writer and WoeUSB, both with default settings.

It was correctly flashed with Rufus on Windows 10, also using the default settings.

With the correctly flashed image, I booted from the first of the two partitions, and the install completed without any issues. This was on an AMD Ryzen 1700 370X-PRO board running in UEFI mode with disabled Compatibility Support Module (CSM).


I installed Windows 10 from a stick made on Arch Linux using Ventoy.

Every other utility I used on Linux caused the same error with the correct ISO.

To me it looks like a repeat of the shenanigans when installing MS Windows on DR-DOS. Except the likelihood of getting sued is much smaller.

  • You can use Ventoy or Rufus or whatever. It is irrelevant. If you would read the accepted answer you would see that this does not solve this problem. If the ISO file is already downloaded as a corrupt file, no software will be able to fix it.
    – Elmue
    Commented Nov 19, 2021 at 5:18
  • 1
    @Elmue The reason I mentioned Ventoy is because it was the only way I could get it to work from Linux. Sure, the ISO also has to be correct, but every other utility I used showed the same error with the correct ISO.
    – danuker
    Commented Nov 20, 2021 at 15:37
  • 2
    Ventoy seems to be a bit different than other image writing software, in that it creates a sort of bootable wrapper with a filesystem that you copy/paste the iso into, and then it boots into ventoy which in turn executes the iso. It solved the problem for me and I was having the exact problems listed in the question here.
    – Marty Neal
    Commented May 1, 2022 at 3:33
  • 2
    @MartyNeal Indeed, it has a very different mechanism, and it was the only one that worked for me from Linux. All other answers say the Linux solutions are "incorrect", but provide no solution for Linux.
    – danuker
    Commented May 2, 2022 at 13:22
  • 1
    had the same "missing driver" error as OP, from a valid WIN11 iso (written to usb stick with dd). Learned about Ventoy from this answer - worked immediately. TYVM
    – Arsylum
    Commented Jul 30, 2023 at 12:51

What solved the problem in my case:

  1. I chose a new pen drive, and set aside all the others I had used before
  2. For Windows ISOs, I decided to use Windows computers to write them, not Linux as I was doing before
    • On Linux, it seems that Gnome Disks, MultiWriter and Etcher are not properly designed to write Windows ISO's
    • Etcher, in particular, even prompts a message about this
    • WinUSB, now called WoeUSB, despite being one recommended Linux solution to create USB drives with Windows ISOs on Linux, presented errors and didn't work for me
  3. Rufus was the software I used
  4. The chosen ISO was one that already worked for my coworkers before on other computers

Possible explanations:

At least one of the issues below was creating the problem:

  • bad pen drives (in this case, bad luck)
  • corrupted ISO (unreliable download provided by Microsoft's servers)
  • improper software to write the ISO to the USB, in particular, Linux USB writers not properly designed to write Windows ISOs
  • 1
    ISO is literally the raw data that sits on the disk, I don't see how linux could write the data to the point that the disk boots... No software is even necessary as you can just us dd if=imagefile.iso of=/dev/sda bs=1m
    – Stephen
    Commented Jun 17, 2021 at 13:53
  • It seems that @Elmue's answer corroborates with my second possibility: unreliable download provided by Microsoft's servers Commented Jun 17, 2021 at 21:54
  • 2
    Worked for me. Using dd from Linux failed but worked with Rufus. File hash matched, so not corrupt. What on earth is it writing that's different? Silver kind of metadata beyond what is on the drive?
    – jozxyqk
    Commented Jul 23, 2022 at 5:17

Google led me here - I had this issue trying to install Server 2016 on VMware ESX.

In my case it was actually a driver issue - I added another CD-ROM device and connected it to the latest vmware Tools ISO, then when faced with the error, I browsed the VMware Tools ISO for the PVScsi driver and then the hard disk was detected by the Windows installation.




** : Failed with Ubuntu and dd. Smooth ride with Windows and rufus.

I'm here to provide details about my case, as an answer. I was trying to install windows 10 on a ASUS ROG STRIX G513IH (ryzen 7 4800h, 512GB nvme). I was downloading the ISO and preparing the USB stick with dd on UBUNTU.

After seeing this post and the answers , I was curious If mine was the same case. But It was not.

I downloaded the ISO from https://www.microsoft.com/en-us/software-download/windows10ISO . I picked the "English 64-bit" and downloaded the ISO. I did a sha256sum for the downloaded ISO and It was same as the value listed in the page, 6911E839448FA999B07C321FC70E7408FE122214F5C4E80A9CCC64D22D0D85EA.

And the file was about 5.4 GBs . And I tried many things like changing the USB port , changing the USB stick , converting the disk to GPT from MBR ...

Later, I tried another link and another way to get the ISO. I travelled to some friend, who has a WINDOWS system . I used the MediaCreationTool21H1.exe downloaded from https://go.microsoft.com/fwlink/?LinkId=691209 and downloaded an ISO via that executable.

The ISO created was around 4.4GB , nothing like the 5.4GB one I downloaded.

And I used RUFUS to create a USB Stick.

And viola . Everything just worked.


The only solution that worked for me was enabling the option "check device for bad blocks [1 pass]" in the programme Rufus, which I used to make the bootable U. S. B. drive to install Windows (using the Windows I. S. O. from Microsoft.com). For instruction on how to make an installation drive using Rufus, see here.

The first time I installed Windows 10 on my new computer, that is how I did it, and it worked fine. When I wanted to reinstall Windows later, I remade the bootable drive, but without setting the above option, because it takes a very long time. Then Windows installation on the new computer complained about the missing media driver every time I tried to install it. I even redownloaded the Windows I. S. O. from Microsoft and created the bootable drive again and again, but to no avail. Changing U. S. B. ports didn't help either. Then I created the drive again with the above option enabled, and it worked fine.

Note that the thumb drive I used was very new, so I doubt whether it truly had any "bad blocks". I don't know what Rufus did, but apparently the checking fixes something. Note also that I never tried creating the bootable drive using the Microsoft Media Creation Tool, because I was using Windows XP, on which it would not run; so perhaps that would have solved my problem as well, had I been able to try it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .