3

How can I open encrypted volumes created by LibreCrypt on linux? These Volume is created by LibreCrypt on Windows7 and is formatted with fat32.

When I tried opening this volume in Linux through cryptsetup, using the following commands.

losetup /dev/loop9 volume.vol
cryptsetup open /dev/loop9 crypt_loop9

I get the error,

Device /dev/loop9 is not a valid LUKS device.

Why am I getting this error?

Aren't LibreCrypt created volumes LUKS compatible?

What is the possible solution?

  • Well the website only says that LibreCrypt can open LUKS volumes, but it doesn't mention anything about LUKS being able to open LibreCrypt ones… – grawity Aug 20 '15 at 6:30
4

LibreCrypt created volumes are not LUKS compatible. They are created in 'FreeOTFE' compatible format. You can create a LUKS volume in Linux and open it in LibreCrypt.

1

try: sudo cryptsetup /dev/mapper/loop9 $desired_name

if that doesn't work then the volume is not LUKS compatible. the solution is to use cryptsetup to create a LUKS compatible volume in linux and mount it in windows with LibreCrypt. that way you can use it in both.

0

@OP, as a fellow observer and tester for LibreCrypt (linux-modder) you would open it with the following command.

sudo cryptsetup luksOpen /dev/mapper/volume $desired_name

(from your example $desired_name would be crypt9_loop)

  • 1
    could u elaborate what is /dev/mapper/volume here. AFAIK, it should be a block device such as /dev/loopX . When this command is successful, the device wil be unlocked at /dev/mapper/$desired_name . And using any of #cryptsetup open ... and #cryptsetup luksOpen ... gives the same error Device /dev/loopX is not a valid LUKS device. – Bharat G Sep 23 '15 at 21:12
  • If it helps, I used Libre Crypt version 6.2 beta on Windows 7 ultimate 64bit to create the volume. – Bharat G Sep 23 '15 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.