0

I have a Dynamic DNS from noip.com and I have installed their client on my home server.

I have also installed WAMPServer to use as an HTTP server (for testing purposes only as I'm a web developer) and I made the port forwarding for port 80 on my router and linked my Dynamic DNS to it.

So far so good. Everything is working fine and I can access my HTTP server from outside network using the Dynamic DNS URL.

Now, my problem is that I decided to run an ERP system called ERPNext on a virtual machine on the same server.

I installed VirtualBox and configured it correctly to use the port forwarding on the machine and installed a Debian Distro and installed the ERP on it and also configured it on port 8080.

Now when I open the browser on my server (host) and type http://localhost:8080 it works fine and I can access the ERP just fine.

What I need is how to configure my router, host and VM in order to access the server from outside network without conflicting with the existing access to my current HTTP server on port 80 (WAMPServer)?

My host machine is running Windows 10 and it might be worth mentioning that I have also configured port forwarding to use Remote Desktop to this machine from outside network and it's also working fine.

Attached is my current router configuration for port forwarding:(note that both HTTP and RDP are working fine now but not ERPNext)

enter image description here

  • Just set the port forwarding to your host machine and it should work... – Kinnectus Aug 20 '15 at 7:49
  • @BigChris Thank you for your comment. As you can see in the screenshot, I have already done so but it does not work. – Hassan Al-Jeshi Aug 20 '15 at 8:11
  • Sorry, I gave you only half the answer... You need to set your VirtualBox VM to have a bridged adapter so it has its own IP on your LAN. You can then configure your router port forwarding to this iP. You may have to change your habits for "localhost:8080", though, and point to your domain name:8080. Source: howtogeek.com/122641/… – Kinnectus Aug 20 '15 at 8:43
0

I have solved the problem and posting my solution here for anyone interested.

From my router, I made a port forwarding rule for a different port (8997) to the host machine instead of port (8080)

Then, on my virtualbox, I made a port forwarding rule for the port (8997) to port (8080) and that solved my problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.