3

1st: How can I tell if ISP is blocking ports?

2nd: How can I tell if problem is related to OS?

Problem began since upgrade to Windows 10.

(Business computer, hence I don't know if I have privileges). (Read "Is there a simple way to detect ISP port blocking?" not relevant).

Settings I tried to configure:

Incoming Mail (IMAP) Server - Requires SSL imap.gmail.com Port: 993 Requires SSL:Yes Outgoing Mail (SMTP) Server - Requires TLS smtp.gmail.com Port: 465 or 587 Requires SSL: Yes Requires authentication: Yes

Error messages:

Log onto incoming mail server (IMAP): The connection to the server failed.

Send test e-mail message: Outlook cannot connect to your outgoing (SMTP) e-mail server. If you continue to receive this message, contact your server administrator or Internet provider (ISP).

Checks I've did:

  1. I ran a ping test on google's SMTP ports they are blocked. (with & without firewall on).
  2. Checked multiple email clients.

Open for tests ideas

ISP tells the problem is my Win10?

  • Thanks Arjan, didn't know the terminology, I've read what you but my computer is a business one, hence I don't have access to the servers I thought about something easier, anyway I'll rephrase my question. – Space_Monkey Aug 20 '15 at 11:02
  • Which gmail smtp ports have you tried? gmail doesn't use port 25 only ports 465 and 587 – Michael B Aug 20 '15 at 11:11
  • Incoming Mail (IMAP) Server - Requires SSL imap.gmail.com Port: 993 Requires SSL:Yes Outgoing Mail (SMTP) Server - Requires TLS smtp.gmail.com Port: 465 or 587 Requires SSL: Yes Requires authentication: Yes – Space_Monkey Aug 20 '15 at 11:12
  • 1
    to reiterate Arjan's advice - rewrite your question saying what you've done, what software you've used, what you've configured it to do. It is extremely unlikely that an ISP is blocking gmail's mail ports though, that would be very very bad for their customer retention! – Michael B Aug 20 '15 at 11:14
  • 2
    "I ran a ping test on google's SMTP ports they are blocked." << what does that mean? you pinged their smtp address? that doesn't tell you if the port is open only that ICMP messages aren't getting through you would need to use something like putty and telnet to the port – Michael B Aug 20 '15 at 11:20
2

If you go to - http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html and download putty.exe

putty gmail SMTP config

click 'Open' at the bottom and you should get

enter image description here If you get that then everything is connecting, if it isn't then you've got another problem. (I very much doubt that your iSP is blocking this though - if it is a work computer it could well be your work doing so)

  • Thanks Michael, did the test - PuTTy can't connect to neither 465 nor 587. PuTTY responds with: "Network error: Connecting timed out" and an empty terminal window. So what could be the problem? – Space_Monkey Aug 20 '15 at 12:59
  • At that point then, you need to eliminate that it is a work computer problem. You need to configure something that doesn't have any other security policy attached, and try it from that. It could be another PC, or a mobile connecting via smtp. (the gmail app will use different ports) - connect it to the same network and try again – Michael B Aug 20 '15 at 13:01
  • Connected with my personal laptop to same network and it failed. Used a different network and it connected with no problems. Michael does it confirms the problem is in the ISP? – Space_Monkey Aug 20 '15 at 13:30
  • From what you have said here, it certainly sounds like it is a network issue. I still find it difficult to believe this is an ISP block (unless you're in China etc!) Has it ever worked on this network? has anything changed recently? who looks after the router? - Maybe raise it with their tech support and point them off to this thread – Michael B Aug 20 '15 at 13:37
  • Thanks a bunch Michael, didn't notice that earlier but the only thing that changed was that I tried to add an email address to my email client that wasn't the company's email but rather one created through gmail. Our ISP provided every employee a Microsoft Exchange email address with the company's domain name. ideas? – Space_Monkey Aug 20 '15 at 14:14
1

You can use PuTTY, as Michael B suggested, or another telnet client, or cURL, or wget, which are available for Microsoft Windows, or even a browser, along with Outgoing port tester to test whether oubtbound access is allowed to a paticular port.

  • 1
    Indeed, that Outgoing port tester website is the easiest way to test generic port blocks! Though some browsers might throw ERR_UNSAFE_PORT or "This address is restricted" at you, but then wget and the like should do fine, like curl http://portquiz.net:587/ or telnet portquiz.net 587. – Arjan Aug 20 '15 at 16:28
0

I'm also looking for an answer to your first question (checking if the ISP isn't blocking outgoing ports) and I'm almost there:

The easiest way to do this is, is to send data to all ports on a server on the Internet and see if we get replies when contacting each port.

But we need to be sure that this server (or combination of servers):

  • Doesn't have ports behind a firewall.
  • Doesn't have any UDP ports open. If they are open we wouldn't (necessarily) get a reply, if they are closed we would receive a ICMP-packet telling that it's unreachable.

... and I don't know about a server of which I can be sure that these conditions are the case

The state of the TCP-ports doesn't matter because when we send a SYN we would receive a SYN/ACK when they are open and a RST/ACK when they are closed but never no answer at all.

I was able to use portquiz.net to test all TCP-ports on IPv4 level except 445 (the owner of this server mentions on his site that this port is behind a firewall of his provider). So I still want to know about:

  • TCP/445 on IPv4 level
  • all UDP-ports on IPv4 level
  • all TCP and UDP ports on IPv6 level

You probably don't want to figure out how to send the correct data to the correct port and figure out if you get a response manually. So I would suggest using nmap:

  • For TCP, run nmap -p 1-65535 server_that_we_need | grep filtered .

  • For UDP , run sudo nmap -sU -p 1-65535 server_that_we_need | grep filtered . (sudo is needed here because you need to be root for UDP-scanning). Remember: we need to be sure that the UDP-ports on the server are closed to get correct output!

    All ports that are visible in the output are blocked by your provider

  • To any possible admin: If you feel that the part where I mention using portquiz violates the rules of not recommending services then you can delete that part. But don't delete the rest of my answer. – Garo Apr 16 '18 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.