3

I have an application that uses an Internet Explorer component to navigate to pages.

In my application i block any ActiveX downloads to improve speed. I also disabled all ActiveX options available in Windows' Internet Options.

But even this way i can't avoid an annoying IE's dialog telling ActiveX controls could not be displayed :

One or more ActiveX controls could not be displayed because either:
1) Your current security settings prohibit running ActiveX controls on this page, or
2) You have blocked a publisher of one of the controls.
As a result, the page might not display correctly.

I know ActiveX controls could not be displayed, that's what it want. I just DON'T want to be bothered by this dialog every minute.

This problem happens in all Windows' versions i tested (2003-10). I noticed the problem happens often if my app is NOT in foreground (ie, another app has focus).

How to stop it definitely ? As i said, i already disabled every single ActiveX option in Internet Options > Security settings.

  • i should be I (upper case)- however, +1 for a good clear post – Dave Aug 20 '15 at 12:43
  • 1
    I Wish I knew I have been running like this for years , and just dealt with it. superuser.com/questions/119791/… this one too, and turning it off (or back on) is not an option. I have been living with things that way so I know what tried to happen. – Psycogeek Aug 20 '15 at 14:32
  • @Psycogeek I could get rid of this security warning some time ago using the solution described. But my main problem now is this f... ActiveX window : / – delphirules Aug 20 '15 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.