15

Note: I will be answering this question myself to help other people who come across this problem in the future. Feel free to submit your own answers if you want, but know that it's already answered!

I am attempting to install the VMware Tools in a Windows 8.1 guest, but the Manage > Install VMware Tools... menu bar button is greyed out. I have downloaded the VMware tools for Windows (I can see it in C:\Program Files\VMware\VMware Player\windows.iso) on the host computer. How can I fix this problem?

23

Even though it seems obvious now, the issue was that the Windows 8.1 guest did not recognize a CD/DVD drive. I had to add one manually in the virtual machine settings. I also found that although the Manage > Install VMware Tools... menu button was then enabled, I still had to manually mount the windows.iso file in the CD drive for the VMware Tools to display in "This Computer". Hopefully this helps someone.

| improve this answer | |
  • 3
    For info: same issue and solution with a Windows 10 guest. – dr_ Sep 21 '16 at 5:46
  • 1
    +1 for no CD/DVD drive installed in a recently P2V'd image. Duuur. – WernerCD Nov 18 '16 at 18:15
  • Never occurred to me that I needed to have a virtual DVD drive to be able to install the VM Tools. In retrospect, makes sense. – Eric B. Dec 2 '16 at 3:44
  • Ok, in my case, for a new Win 10 machine, I needed to apply two solutions: change Proxy settings in File->Preferences to "No proxy", and remove the CD/ROM, shutdown the machine, add a new CD/ROM and start again the manchine. Only in the sequence I was able to activate the option. – Eagle Jan 3 '19 at 15:55
2

For me what worked was to change the Floppy disk type to "physical". It doesn't make any sense because I obviously don't have a floppy disk connected to my laptop, but this post suggested it, and it worked.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.