1

I recently upgraded from Windows 8.1 to 10. In 8.1 I used default system driver for sound card in my Toshiba Portege Z30 (it has different settings for headphones/speakers)

But Windows 10 always automatically instals Realtek High Definition Audio. I can delete it all day, it always comes back even though default driver works fine as in 8.1.

I tried the tool to hide this update, it did not help.

Is there any way how can I keep the default driver? Disabling Realtek in Device Manager did not help - I am left without sound.

Thanks, this is driving me crazy.

EDIT: Disabled installing driver software via Windows Update, but it still instals "Realtek Semiconductor Corp. - Audio Device, Other hardware - Realtek High Definition Audio" and requiers restart.

1

Try this:

Control Panel>System>Advanced system settings>Hardware tab>Device Installation Settings button

tick "never install driver software from Windows Updates"

enter image description here

  • Thanks, seems like solution.. However this will cause problems when I plug any new hardware right? – Filip Aug 20 '15 at 20:40
  • I assume so, I never trusted Windows update for drivers, too may blue screens and other serious issues. I always download them from the manufacturer and install at my convenience. – Moab Aug 20 '15 at 20:50
  • 1
    You can probably still use the "old school" driver wizard to obtain drivers from Windows Update, on demand-ish. – Daniel B Aug 20 '15 at 21:18
  • Looks like this did not help :/ Windows Update today installed "Realtek Semiconductor Corp. - Audio Device, Other hardware - Realtek High Definition Audio" and wants PC restart. – Filip Aug 21 '15 at 8:14
  • WTF Microsoft, what is that setting for then, I hope W10 bombs worse than Vista did. – Moab Aug 24 '15 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.