I recently upgraded to windows 10 from windows 8.1 pro. As a result, many of my programs are scaled big and blurry. Even the default windows one like device manager. See how it is kind of fuzzy and big?

enter image description here

To fix this I have to right click on a program and go to its properties and check the box "Disable display scaling on high DPI settings.":

enter image description here

Which is kind of annoying - I didn't have to do that before. For some programs though, I do not have this problem. It only seems to be for a certain set of them or something.

Here are my display settings:

enter image description here

Can anyone help me with this? It is really annoying

  • 3
    Have you tried moving the slider underneath the text that says "Change the size of text, apps, and other items" down from 125% to 100%? You'll probably have to log out and back in.
    – Mokubai
    Commented Aug 20, 2015 at 20:40
  • @Mokubai Yes I have. But I am on a 15 inch laptop so doing that makes everything tiny on my screen. I used 125% in windows 8.1 too and it was fine. The update to windows 10 messed things up and I am not sure how or why.
    – Micro
    Commented Aug 20, 2015 at 20:47

3 Answers 3


Here is the solution that worked for me, running with scaling set to my desired 125%:

Open notepad and paste in the following three lines:

REG ADD "HKCU\Control Panel\Desktop" /v DpiScalingVer /t REG_DWORD /d 0x00001018 /f REG ADD "HKCU\Control Panel\Desktop" /v Win8DpiScaling /t REG_DWORD /d 0x00000001 /f REG ADD "HKCU\Control Panel\Desktop" /v LogPixels /t REG_DWORD /d 0x00000078 /f

Save the file as DPI_FIX.cmd someplace easy for you to find. Open the Group Policy Editor (enter gpedit.msc from the search bar). In User Configuration, click on Windows Settings then Scripts (Logon/Logoff). Double click Logon in the right pane. In the Scripts tab, click Add, then Browse, then navigate to your .cmd file, click Open, click OK, click Apply, click OK. Then sign out or reboot. Login to your account the first time after adding this script so it will be applied. It may not take effect the first time (if so sign out or reboot again). After that, it should work every time.

*Kudos to EShirou at Tenfourms for originally providing this solution.

Other things I tried that did NOT work:

  • Changing drivers.
  • Creating the above .cmd file and adding it to the the Startup folder or the Task Scheduler (it only worked on every OTHER sign in / reboot).
  • I couldn't even download the "blurry fix" .exe as the site would not load for me, but I do not want to risk running a strange .exe file every time I start the computer.

I've managed to get sharp fonts in CMD, Device Manager, etc at once using standard Windows settings UI (i.e., without changing the compatibility settings or using the auto-start registry script or 3rd party applications).

Basically, you need to go to the Control Panel > Appearance and Personalization > Display and set a custom scaling level to 125%.

The nuance is that the UI won't let you to apply the setting if you already have the recommended 125% setting in the Settings > Display. But there are at least two workarounds:

Workaround 1: You can just set the scaling level to some other value in the Settings > Display UI, just before changing the settings back to 125% in the custom scaling level UI.

Workaround 2: You can set the custom scaling level to some other value in the custom scaling level UI, Apply, choose to re-logon later in the popped dialog, then set the custom scaling level back to 125%, Apply, and re-logon manually.

I've tested both workarounds and they both worked on two of my laptops.


This is an issue that others also run into. There is a DPI fixing tool that can revert to the older DPI algorithm.

When you have a widescreen, with a resolution of 1920x1080 or higher or a bit lower, in Windows Vista, 7, 8 and 8.1 you would put your DPI scaling to 125% or higher to make text and images appear larger and more easy to read. But when you put the DPI scaling to 125% in Windows 10, you see in a lot of dialogs and windows the font gets very blurry. It does not matter if you are using the regular or custom Windows DPI scaling functions at your 'Screen properties'. Text will get blurry on 125%.

Run the tool and select the old way:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .