2

I want to be able to monitor the performance of some remote machines from my local machine.

Here is my setup so far:

  • local machine: Windows 8.1 Professional 64-bit;
  • remote machines: Windows 8.1 Professional 64-bit;
  • all machines in the default WORKGROUP workgroup - no HomeGroup, no domain;
  • all machines in the same private network ("private" as in Windows 8.1's concept of "public"/"private" network)
  • for convenience, same username and password on all remote and local machines - let's call the user "bob";
  • "bob" belongs to these groups on all remote and local machines:
    • Administrators
    • Event Log Readers
    • Performance Log Users
    • Performance Monitor Users
  • These services are enabled and running on all remote and local machines:
    • Performance Counter DLL Host
    • Performance Logs & Alerts
    • Remote Procedure Call (RPC)
    • Remote Registry
  • Allowed apps and features in Windows Firewall on the remote and local machines:
    • Performance Logs and Alerts

So far, The only thing that I can do from my local machine is to connect to a remote computer and start a Data Collector Set:

You can see the button to start the data collector set is enabled.

But then I cannot stop it:

The "stop" button is not enabled after I start the data collector set.

And if I disconnect and reconnect, all data collector sets completely disappear:

Where have all the collector sets gone? Gone to graveyards, everyone. When will they ever learn?

Also, at no point can I get a report of the remote data collector set.

So I figure that maybe instead of using a remote data collector set, maybe I should use a local data collector set, but with remote performance counters, so I try to browse to the remote computer to add performance counters:

enter image description here

But then it asks me for username and password:

Why doesn't this work the same way as file sharing? It's the same username and password as the local machine. Don't ask me again!

After I supply the username and password and click "OK", I have to wait a whole minute, and then it comes back with this useless message:

enter image description here

It's really frustrating. Windows clearly could find the remote computer when I started the remote data collector set. So why can't it find the same remote computer when I want to access its performance counters? The message tells me nothing about what's missing. I also couldn't find any useful information on MSDN/TechNet.

2

But then I cannot stop it

To stop the monitoring process, type the following command, and then press enter:

monitor \\remotecomputer stop

How to Monitor Performance of a Remote Computer Without Logging on to It

To log data and generate alerts on a remote computer without having to log on to it, follow these steps:

NOTE: In the following steps, replace with the name of the computer that you want to monitor.

  1. Install the Windows NT 4.0 Resource Kit on the remote computer.

  2. At the local computer, use Windows NT Performance Monitor (Perfmon.exe) to create a workspace file:

    • Start Performance Monitor, and then click Log on the View menu.
    • Add the relevant counters, specifying all objects you want to log and the alerts you want to generate.
    • On the Options menu, click Log.
    • In the File Name box, specify a name for the log file using the .log extension.
    • Click one of the logging interval options, and then click Save to save the logging options.
    • On the File menu, click Save Workspace.
    • In the File Name box, type a workspace file name using the .pmw extension, and then click Save.
    • Quit Performance Monitor.
  3. Copy both the workspace file you just created and the Datalog.exe file included with the Windows NT 4.0 Resource Kit to the %SystemRoot%\System32 folder on the remote computer.

  4. At the local computer, set up the Data Logging service for the remote computer:

    • At the command prompt, type the following command, and then press enter:

      monitor \\remotecomputer setup

      NOTE: This command registers the service with Windows NT Server 4.0. You need to run the command only once for each computer you want to monitor. If you receive the following error message

      Failed to create Service

      it means that you have already run the command once.

    • To use the workspace file for logging, type the following command, and then press enter:

      monitor \\remotecomputer filename

      where filename is the name of the workspace file you copied to the remote computer.

  5. To start the monitoring process, type the following command, and then press enter:

    monitor \\remotecomputer start

  6. To stop the monitoring process, type the following command, and then press enter:

    monitor \\remotecomputer stop

    • After you stop the monitoring process, you can view the log file in Performance Monitor. For instructions about how to do this, see Help in Performance Monitor.

    • Also, you can use the Schedule service and the AT command to schedule monitoring to occur at a set time. For example, if a server slows down noticeably between 2:40 A.M. and 2:50 A.M. every weeknight, you can log the data for that period without being physically present by typing the following AT commands:

      at \\remotecomputer 2:30 /every:m,t,w,th,f monitor start

      at \\remotecomputer 3:00 /every:m,t,w,th,f monitor stop

    • If you want to be reminded about the log, type the following command, and then press enter:

      at \\remotecomputer 3:00 /every:f net send yourusername 'The Monitor is stopped. The log contains data for this week!'

Source https://support.microsoft.com/en-us/kb/246758

-1

Another thing to consider is Click Properties (icon on the top) --> General Tab --> Change “Run as “to the windows account that has permissions in remote machine That worked for me, after adding the user account to Performance Log user groups.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.