0

What is happening:

I have a PC running Windows 8.1 and a Mac running Mac OS X 10.6.2. I also have a USB which is 8GB. My Mac isn't connected to the internet but my PC is. When I connect my USB to my Windows Machine it works as usual. It shows it's formatted as FAT32. However when I insert it to my Mac it doesn't show as a device but in Disk Utility it shows that it isn't mounted:Disk Utility


When I try to mount the drive it says that I need to run First Aid on it. But nothing different happens.

I was wandering if there was a way to open Mac OS extended/HFS/HFS+ USBs on Windows. This is the only way my Mac reads it.

  • What about using DropBox/Google Drive/Live? You could copy the files there and copy to your Mac or vice versa. – Leptonator Aug 21 '15 at 14:25
  • Try plugging the USB disk in and rebooting your Mac... does the disk get mounted this way? – Kinnectus Aug 21 '15 at 14:26
  • I can use any of what you recommended because I also stated that I haven't connected my Mac to the internet – ss4566654768 Aug 21 '15 at 14:39
  • I will try doing that "rebooting your Mac..." – ss4566654768 Aug 21 '15 at 14:39
  • 3
    Format it as FAT on your Mac then use it on your Windows machine. – qasdfdsaq Aug 21 '15 at 15:56
0

Fixed it. It turns out I was booting into safe boot by accident. I booted into normal mode and it worked. Although I had to do what qasdfdsaq said.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.