4

My Sql server 2012 has stopped working and now its not letting me login. Here is the error:

https://drive.google.com/file/d/0ByGXmosQgHUqdGw4alFSb3otVkk/view?usp=sharing

TITLE: Connect to Server

Cannot connect to 192.168.1.2.

------------------------------ ADDITIONAL INFORMATION:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 53)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=53&LinkId=20476


The network path was not found

------------------------------ BUTTONS:

OK

please suggest what should I do

  • I have edited the question. Please have a look – Vikas Bansal Aug 21 '15 at 16:58
  • It not clear what your question is. The current error doesn't indicate an inability to log into the server, the server on the other hand, cannot even be communicated with. – Ramhound Aug 21 '15 at 17:05
  • I have configured a Loop back adapter in order to connect my local database with an IP 192.168.1.2 with user name sa its not working now – Vikas Bansal Aug 21 '15 at 17:08
  • The error is specific. There is nothing at that address that is even responding. No attempts to access the server is being remade. Verify all configuration to determine the cause of this behavior. – Ramhound Aug 21 '15 at 17:10
  • If you changed the computer name, then you won't be able to connect. You have to uninstall and install again. – MorrisIriga Oct 26 '15 at 10:17
3

Was facing the same issue. Realized that Windows 10 had turned off the SQL Server Service.

To resolve, open 'services.msc' and start service of SQL Server ()

1

Same error here but the connection problem happens only when using the computer name AND only from the server itself (clients can connect)

If instead of using "[servername]\[instancename]" you try to connect with "[serverip]\[instancename]" it works. That is the only workaround I found so far. A word from microsoft would be very appreciated.

moreover... it seems like the problem doesn't affect OSQL.

0

probably because the service can not run Windows 10 memory compressor. It also happened to me. Windows 10 version 10525.

  • What is the SQL Server version? Is there any workaround? – Martheen Cahya Paulo Aug 31 '15 at 7:58

protected by Community Oct 26 '15 at 12:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.