0

I just discovered, that BIOS was not in AHCI mode, and that's why my newly bought SSD was at low speeds. I installed a Linux on the SSD, it works perfectly in AHCI mode. Now my problem that if I want to boot from the HDD, which contains the Windows7 x64, then the BIOS stucks this

enter image description here

and when the DVD is plugged into SATA, then it stucks by this

enter image description here

I don't understand what the problem is, but it certainly does not want to boot when these drives are present. I cannot even start the BIOS menu, I have to unplug everything from SATA, if I want to do that.

I have a GA-EP43T-USB3 motherboard. (I guess it is rev1.) http://www.gigabyte.com/products/product-page.aspx?pid=3316#ov I was suspecting that a BIOS update would solve this issue, but I am not sure what to install from here: http://www.gigabyte.com/products/product-page.aspx?pid=3316#bios and anyways I have doubts whether this would work.

I followed the regedit suggestion described here by Microsoft: http://answers.microsoft.com/en-us/windows/forum/all/windows-7-64-bit-does-not-boot-with-ahci-enabled/1ed33ae9-b2ff-4d1f-b28c-406153e04faa?auth=1 but it did not have any effect. (I have similar Barracuda than the asker have.)

Any suggestions?

1
  • The registry tweak ought to work - with one caveat. If it doesn't see the ahci drive immediately at next boot it will reset & you have to do the tweak again
    – Tetsujin
    Aug 22, 2015 at 10:25

1 Answer 1

0

This is a known Gigabyte AHCI BIOS issue. BIOS update does not help, they never fixed the bug, at least it is not in the release logs. I updated the BIOS from F2 to F4 (not F5D, I don't want to have beta BIOS). The only difference I got is the infamous "23" message. (The registry tweak is a Windows issue, it has nothing to do with this bug, since this happens by drive recognition.)

It can be worked around this way by HDDs, but my DVD has the same issue, so it wont help. I'll stay with the IDE mode. It has slightly lower speed by the SSD, but that's irrelevant. TRIM works, that's what really matters.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .