2

I have successfully created a backup image of my laptop's hard drive using CloneZilla. Before making system changes I want to verify that the backup is fully restorable and can be booted from.

I have successfully restored the image to an external USB drive and tried booting from that, however it always seems to load the copy of windows 8.1 from the local disk (to check, I made a simple change to the desktop background after the backup operation). I have tried disabling the boot option in the BIOS for the local disk but I suspect it is reading the MBR GPT boot information from the external drive, then using that information to load the file system on the local disk (please correct that assumption if it's wrong) There is no option in the BIOS to disable the local disk entirely.

I then tried booting from the external disk on an isolated PC and I get a blinking cursor (HAL/Driver problem?)

I've also tried using VirtualBox to boot from the USB device using both;

  • a restore of the backup image
  • and a disk-to-disk clone

Both of these result in a "no bootable medium found" message from VirtualBox.

Clearly I don't want to perform an actual restore to the local disk, in case the backup isn't fully functional.

How can I test that the CloneZilla backup I've created is recoverable in a safe environment?

Update

Starting afresh, I recovered the backup image to the external drive again. When plugging it in Disk Manager reports an error

The disk is offline because it has a signature collision with another disk that is online

Here's what it looks like when the disk is brought online.

Disk Manager Screenshot

I wonder if the "Bring Online" operation is causing partition flags to be lost? If that's not the case then shouldn't CloneZilla be replicating these attributes as part of the backup?

  • Presumably disconnecting the laptop's drive - if accessible - also results in a "not bootable" error similar to the isolated systems? (still, good question) – bertieb Aug 22 '15 at 14:15
  • Unfortunately the drive is not accessible without loosening a few screws, since this is a brand new laptop I'd rather not void the warranty just yet, especially without a verified backup! :) – Red Taz Aug 22 '15 at 14:18
  • Quite sensible! Though unless the screws are sealed I wouldn't have thought it would be a warranty-voiding process... but don't trust me on this! Have you examined the disk-to-disk clone with something like diskpart or similar too see if the partition's boot flag is set? – bertieb Aug 22 '15 at 14:22
  • I've not used diskpart but I have just noticed in Disk Management the primary partition on the original disk is marked with both "Wim Boot" and "Boot" whereas the clone is flagged only with "Wim Boot" – Red Taz Aug 22 '15 at 14:30
  • Using diskpart the relevant volume is not marked as boot, how do I fix that? – Red Taz Aug 22 '15 at 15:00
0

The "not a bootable disk" on the clones makes it sound as though the boot flag hasn't been set on that.

How do I check if the boot flag is set?

Good question. diskpart is your friend:

  1. Start a regular command prompt and run diskpart from that; or you can run diskpart from the Start menu or diskpart.exe directly. It will ask for admin access.

  2. list volume will list volumes and their flags. The boot flag show up under the info column:

    diskpart screenshot

    Here you can see my C: volume has the boot flag set, but the removable drive (E:)1 does not.

How to set boot flag on partition using bootsect

So, let's assume your backup image is accessible (but not bootable) under the letter E:, you can verify the files are there but see that it's not got the bootflag set using diskpart. well, you can use bootsect to set the boot flag2.

  1. Start an administrative command prompt from the Win+x (Power User Menu)

  2. G:

  3. cd boot

  4. bootsect /nt60 G:

Done!


1 I think that's a Debian netinst partition...

2 or switch between old style ( < Vista) and newer; see the Technet page for more info

  • Updated NTFS filesystem bootcode. The update may be unreliable since the volume could not be locked during the update: Access is denied. restarted and checked diskpart still no boot flag :( – Red Taz Aug 22 '15 at 15:43
  • @RedTaz make sure nothing is accessing the drive (or open Explorer windows etc); and/or add the /force flag (at your own risk!) – bertieb Aug 22 '15 at 15:49
  • Correction to the above. Using the /force option reports a successful operation, however, reboot & check diskpart the elusive boot flag is still missing – Red Taz Aug 22 '15 at 15:49
  • How strange. Is it marked boot before reboot in diskpart? Is it an active partition? – bertieb Aug 22 '15 at 16:44
  • Using a fresh copy of the clone, the bootsect reports success, immediately after diskpart still reports no flags for that volume – Red Taz Aug 22 '15 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.