28

So here's a weird issue: When you first turn on this desktop computer, it does not recognize that it has a hard drive in it. However, if you then press the reset button, or turn it off and back on quickly enough, the hard drive will be recognized. In all other aspects, the drive works perfectly, with a S.M.A.R.T test showing no errors. What could be the cause of this, and is there any way to fix it?

  • 13
    Once in the distant past I managed to work around such a problem by leaving an unformatted floppy in my floppy drive, which slowed down the boot just enough for the hard disk to spin up. – kasperd Aug 23 '15 at 19:47
  • haha, that's creative. By any chance do you remember if the hard drive failed soon afterwards? – Blaine Aug 24 '15 at 22:56
  • 1
    That hard drive never failed. – kasperd Aug 25 '15 at 7:03
48

It could be that the BIOS is not waiting long enough for the hard drive to spin up before continuing to boot. Many BIOSes have an option for "hard drive spin up time" which can delay the boot process for a couple of seconds while the hard drive spins up.

If you can get into the BIOS then I would look for that option and see of you can extend the delay.

If this is a recent occurrence then it could be a sign that the hard drive motor is beginning to fail and can no longer spin up as quickly as it used to. This would be a bad indication as it may not be able to spin up at all soon.

  • 22
    Thank you!! I couldn't find an extend delay option in this particular bios (though i have seen one in others). What did work however, was to disable quick boot, which let the system waste time checking ram so that it could give the hard drive enough time to spin up :) – Blaine Aug 23 '15 at 10:12
  • 20
    @Blaine - it's great that you found a working solution, but consider this drive as failing! Make backups, and make plans for replacing it soon. – Davor Aug 24 '15 at 10:19
  • 2
    I had a similar issue with an SSD with a crappy controller. It had a sandforce controller, though I can't recall the manufacturer. Apparently the startup time between when power was applied and when the drive became enumerable by BIOS was dependent on the amount of data stored on the drive. Worked perfectly when I first put it in the computer; failed to enumerate after installing the OS. Worked again after erasing the disk. I ended up returning the SSD and replacing it with a Samsung device. – alex.forencich Aug 25 '15 at 3:12
24

This might be an effect of more power required than is available just when the disk spins up.
An already spinning disk (from an earlier start-up attempt) reduces the power requirement for that disk.

Check that the PSU has a good enough rating for the overall system.

One can also suspect the effect to be an indication of trouble with the PSU.

  • Exactly. If the PSU can't quickly deal with the inrush current surge from booting the board and the HD motor, it might be going out. – cde Aug 25 '15 at 6:30
0

I have a similar problem sometimes if the temperature changes a lot.
It usually says "cannot detect a hard drive".

Remedy

  • Unplug power
  • Remove the IDE cable,
  • spray it with electronics contact cleaner,
  • pull the cable in and out a few times.

Has worked many times for me.

  • this could be a good answer, but it is very hard to read, could you try to make some format? – Francisco Tapia Sep 4 '15 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.