0

I'm trying to use my iPhone 5s internet connection from my PC (Windows 7) using USB cable. This all used to work but then I updated my iOS version to 8.4.1 (latest) recently and this now appears to not work any more.

When plugging in the phone the Apple driver appears to get successfully installed and I get a network connection icon. However, it has a (!) sign that it cannot access the internet.

Things I have tried and havent fixed the problem: - downloaded latest iTunes, uninstalled all of iTunes from my PC and installed the new version - tried using the iPhone as a hotsport via wifi from my iPad and this works (i.e. the internet connection from iPhone over wifi works). - disabling my PCs firewall

I find this very suspicious that the quite recent upgrade I did to the new version of iOS on the phone seems to coincide with USB tethering not working anymore (but this could be a coincidence I guess).

Any ideas would be great.

0

This problem turned out to be the DNS settings that Windows 7 was using for the "Apple Mobile Device Ethernet" connection. In the "Internet Protocol Version 4" protocol I changed the DNS servers to ones I usually use and then it started to work (there was only one DNS server, the primary one, and I'm guessing it was dead/had problems).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.