12

After the recent upgrade to Windows 10, the good ol' AppCompatFlags method no longer works. Which is something like this -

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Windows\\System32\\cmd.exe"="~ RUNASADMIN"
"C:\\Windows\\SysWOW64\\cmd.exe"="~ RUNASADMIN"
"C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\powershell.exe"="~ RUNASADMIN"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Windows\\System32\\cmd.exe"="~ RUNASADMIN"
"C:\\Windows\\SysWOW64\\cmd.exe"="~ RUNASADMIN"
"C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\powershell.exe"="~ RUNASADMIN"

Is there any other way I can make command prompt run as admin by default? I'm not talking about the CTRL + SHIFT + ENTER to run as admin or through a shortcut as they are all very inconvenient.

(E.g. say when you SHIFT right click in a folder and open a new command prompt, it's not gonna run as admin by default and there's no way you can make it run with the privilage without editing the context menu.)

9
  • AppCompatFlags > RUNASADMIN still works here, running Win10 1511 10586.218
    – w32sh
    Apr 22, 2016 at 11:29
  • Odd, is it the same exact path and key? It's not working here.
    – StillAzure
    Apr 22, 2016 at 11:31
  • Yes. I used your REG file infact.
    – w32sh
    Apr 22, 2016 at 17:20
  • Does running this command show any integrity violation for sysmain.sdb? sfc /verifyfile=C:\windows\AppPatch\sysmain.sdb
    – w32sh
    Apr 22, 2016 at 17:36
  • Nope, by the way this was tested on multiple fresh installment of Windows 10. All latest builds.
    – StillAzure
    Apr 23, 2016 at 3:31

4 Answers 4

8

STEP 1

Open the Start menu and click All apps find the program you want to always run in administrator mode and right-click on the shortcut. Click the Open file location (only desktop programs will have this option)

screenshot of start menu

STEP 2

A File Explorer window will open to the location of the program you want to access.

Right-click on the program and click Properties from the pop-up menu.

menu screenshot

STEP 3

In the Properties window, click the Shortcut tab and then click Advanced

screenshot

Step 4

In the Advanced Properties window, check the box next to Run as administrator and click OK.

screenshot

The program will now open in administrator mode.

4
  • 4
    That won't work if you run Command Prompt from Run though, which is what I use often.
    – StillAzure
    Feb 10, 2016 at 15:12
  • @StillAzure I have spent like 2h just looking on how to make this work. Here is the solution - make it as in the answer above, create a shortcut of that .exe . Change that shortcut to whatever command you like to enter in run - for me I set it up as cmda - command prompt admin. Move it to C:\Windows folder. Now you can run it easily. Nov 20, 2017 at 0:02
  • 1
    @CandidMoon It would still kinda be a botched solution, but better than nothing :p
    – StillAzure
    Nov 20, 2017 at 4:17
  • This also work if you apply this to the shortcut of .bat Mar 14, 2020 at 12:30
2

Actually, there is a way to do it:

  1. You need to go to C:\WINDOWS\system32\ and take ownership over cmd.exe. You can do it by Right click->Properties->Security->Advanced->Change (in blue with the shield icon).
  2. Now you can give yourself access to modify it, or whatever you need to rename it.
  3. Once you've done that, rename it to whatever you like.
  4. You can access it's compatibility properties tab and tick "Run as administrator"

Voila! Done!

But, not quite, no program will now be able to find cmd.exe since it no longer exists. But fret not, open your shiny new renamed cmd and run this command:

mklink "C:\WINDOWS\system32\cmd.exe" "C:\WINDOWS\system32\cmdWithNewName.exe"

Congrats, you now have a dummy cmd.exe that will point to your renamed exe that is always ran as administrator.

Remember to change the permissions on the new "cmdWithNewName.exe" back to being only read & execute. After you've done that, you can change the owner of the file back to TrustedInstaller by entering "NT SERVICE\TrustedInstaller" in the object name field where you originally took ownership of the file.

This locks the file from any further tampering, lessening the security risk.

1
  • Running the renamed cmd shows The system cannot find message text for message number 0x2350 in the message file for Application. (c) Microsoft Corporation. All rights reserved. Not enough memory resources are available to process this command.. Running dir within it also results in similar errors. Partial Solution: Create a "renamed cmd" counterpart to the file ‪C:\Windows\System32\en-US\cmd.exe.mui. See superuser.com/a/1525215/881691.
    – Unknow0059
    Apr 8, 2022 at 19:02
1

After following the instructions above, making the program start in administrator mode by default, I added a shortcut key, CTRL + ALT + E to the properties options, works great.

enter image description here

-3

If you are using Windows 10 File explorer, click on "File" (left top corner) & mouse over "Open Command Prompt". There is an option to run as administrator.

3
  • Welcome to Super User! Have another look at the OP's question. He wants to configure the Command Prompt so that it runs as Admin by default. Please revisit your answer accordingly. Thanks for contributing. Aug 24, 2015 at 21:29
  • 1
    and there's an easier way in windows 10: press win+X
    – phuclv
    Jan 5, 2017 at 7:01
  • @phuclv, whoa, that's pretty cool
    – brgs
    Aug 12, 2018 at 15:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .