In Windows 7, if you drag a window by its title bar to the top of the screen, the window maximizes.

This annoys me -- if I am dragging a window to the top of the screen, it is because I am positioning it so I can see it and something else. If I want to maximize, I'll click the maximize button.

Does anyone know how to turn off this feature?

2 Answers 2


I love this feature, but this link answers your question.

  • Go to Control Panel.
  • Click on Ease of Access link or Ease of Access Center icon.
  • Select Change how your mouse works or Make the mouse easier to use option.
  • Tick the check box for Prevent Windows from being automatically arranged when moved to the edge of the screen with the mouse under “Make it easier to manage windows” section.
  • Works. Thanks. I knew it was in there somewhere. Jan 15, 2010 at 14:36
  • Glad to help. On my two-monitor setup, I prefer the snap feature though.
    – user3463
    Jan 15, 2010 at 20:33
  • 2
    The maximize on top is annoying. I love the left/right windows though.
    – Keltari
    Sep 10, 2012 at 8:39
  • 8
    Unfortunately, that also disables the drag/snap to sides of screen as well. There is a practical use to snapping to the sides because the titlebar is wide enough that you will rarely trigger a snap by accident. The snap-to-top is annoying because the titlebar is short, so it triggers almost every time.
    – Synetech
    Nov 21, 2013 at 21:37
  • This answer works in Windows 10 anniversary update (latest version at time of writing).
    – yzorg
    Nov 17, 2016 at 18:08

And for those who frequently reinstall windows, I found a key in Registry responsible for this. Just paste the code below into a notepad and save it as something.reg file and run it. You'll have to log off for it to take effect though. (and "1" makes it snap again)

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Desktop]

Not the answer you're looking for? Browse other questions tagged or ask your own question.