2

I am using fedora 22 (gnome) on a Dell Vostro 3558 - the touchpad is not working and I cannot figure out why.

It seems to be detected:

$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ DLLC6C1:00 06CB:796A                      id=13   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]

and I also see it in gnome settings - I can move the switch to on or off but it has no effect. I can't get the pointer to move unless I plug in a usb mouse. I know this hardware is new (Spring2015) but my internet searches provide no help so I am guessing there is something simple wrong here.

I am running fedora 22 x86_64, log in with gnome (not wayland doesnt work there either). Tried Fedora Live (22 and 21) with no luck. It does work when I go into Setup, or if I boot a Windows install disk so I do know the hardware is not broken.

I was hoping for some help troubleshooting this.

FYI I asked this earlier fedora 22 synaptics touchpad not working

Edit 1: Somehow it worked after I played around with some xinput commands (which are not in bash_history unfortunately. It worked through a few reboots until I powered off. Does not work anymore. What I do know is when working, xinput --list does not show the DLLC6C1:00 06CB:796A device (also detected as a touchpad). Maybe the solution is to find a way to keep that device from being added? usingf xinput --disable does not help.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.