I have a 500GB Seagate Laptop HDD that I received from a scrapped laptop that I am trying to format. I managed to format one of the partitions but cannot remove or format the remaining ones.

Here is a view of the HDD in the Windows Disk Management Utility. enter image description here

When I right click on any of the partitions except the F: partition I get the context menu with only one option "help".

Any idea how I can remove the other partitions and format the entire drive?

  • Have you gotten all the data out? Would running a livecd and something like dban or shred be an option? – Journeyman Geek Aug 25 '15 at 0:52
  • Yes, it wasn't my laptop. I was just trying to do it without outside softwares. – KDecker Aug 25 '15 at 1:00

Ok so what you need to do is "clean" the disk. Open an elevated command prompt. Click Start and type in cmd and right click on that and click Run as Administrator. Now type in diskpart and hit enter.

Type in list disk and you will get an output of the hard drives and flash drives you have. Then type in select disk # # being the number of the disk you want to wipe. After that type in clean. This will wipe the entire disk.


C: is the boot partition

After Windows 10 upgrade there were eight partitions. Booted into a Live USB Linux and run gparted, then simply deleted all partitions except the required EFI partition and C: partition, and even shrunk the C: partition to make room for a dual boot later. (Note: did not move the C: partition, just shrunk it.)

Disk Management

At reboot, Windows 10 started just fine with just the two partitions. I even forgot and did a hybrid Windows shutdown before all this (where it saves state to speed next startup) so it started fine but showed all those old partitions for a while, crashed on disk management rescan, but next full start it was okay from then on, after making me do a diskcheck. Feels quite stable to delete all but EFI and C: when your C: is your boot partition.

Reference reserved partition being deletable, and efi partition being required.

C: is NOT the boot partition

I repeated the above on a different system where the vendor (Acer) booted from a special partition first, which wasn't my EFI or C: partitions, and Windows wouldn't start any longer, because I deleted the special vendor boot partition. Note, it did boot Windows (EFI partition worked) but couldn't find C: and had a Windows 10 version of a blue screen which is lighter blue and some sort of error about no boot partition found.

Ordinarily to fix this boot your Windows 10 recovery USB stick then pick: language US | troubleshoot | advanced options | startup repair | Windows 10. Except this wouldn't help because the vendor tweaked the EFI and C: partitions to not be fixable.

My fix was to boot Windows 10 recovery USB, take the options that lead you to a command prompt. There, you can try with the usual bootsect /nt60 C: and look for Windows installations bootrec /scanos and mine found none. Then ran diskpart, did the usual list volumes mine happened to be 2, select volume 3, remove letter C, select volume 2, assign letter C, to make C: where Windows is installed (it's temporary).

It showed as hidden, so to unhide it couldn't simply use attribute volume, got a not found, ended up having to set id=ebd0a0a2-...etc to make it a normal Data partition, then changed the attribute to not hidden. Running attribute volume should show "no" on all four lines. At that point, C: is not hidden. Had to attribute volume clear nodefaultdriveletter so on boot it would assign C: normally. Just for grins, changed the EFI partition to be an EFI partition (happened to be 1) with select volume 1 and set id=c12a7328...etc. Still shows hidden but that's okay, EFI is normally hidden.

So my partitions are not longer messed up, removed all the weirdness the vendor did to them. But still not finished, had to setup C: to boot correctly. Tried bcdedit /enum and saw some odd boot settings in my C:, so to undo that bcdboot C:\Windows /v. The last thing is the secret sauce.

At this point bcdedit /enum showed more normal looking things and it booted properly.

Disk Management

Above, that first 301MB unallocated was the original boot partition I deleted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.