4

I have a key on my keyboard that brings it up, and I hit all of the time accidentally.

It's a proprietary Logitech Calculator key, and their own program doesn't let you remap it.

This seems to be a hard problem that many people are failing at solving - the google results were awful. Apparently if you munge the EXE file windows will just fix it against your will.

2

2 Answers 2

2

The answer is Applocker.

  1. Start=>Run=>secpol.msc
  2. Security Settings=>Application Control Policies=>Applocker
  3. Add new rule (type=path) to deny everyone %SYSTEM32%\calc.exe
  4. Make sure to let it create the default rules it "wants" to create when you do this.
1
  • This removes Windows 10 Calc by admin powershell: Get-AppxPackage *windowscalculator* | Remove-AppxPackage
    – Tomblarom
    Jun 23, 2018 at 12:21
0

In order to disable the calculator, please follow the guideline Disable Calculator Key on Keyboard

1) Download SharpKeys, Install SharpKeys on Your Computer.

2) After the installation, Launch SharpKeys, it will come with a warning of writing a key to the registry, Click on OK.

3) The SharpKeys Window will open

4) Below, Click on Add.

5) Select the Calculator Key (From Map this Key Table) and To this Key, You Select Turn Key Off (00_00) inorder to disable the key, this Click ok OR Click on Type Key and Press the Calculator Key For Map from this Table and then select Turn Key Off (00_00) inorder to disable the key.

6)Then Below on the right hand corner, Click on Write to Registry (Where the Orange Box is) https://latestsolution.com/disable-or-remap-calculator-key-on-your-keyboard/

1
  • 1
    The accepted answer requires no 3rd party software installation. :)
    – ClioCJS
    Jan 7, 2018 at 8:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .