0

I'm currently encountering issues with some tools that connect via SSH to a remote machine (Eclipse's remote deployment) to deploy files automatically. Around 90% of the time, when I initiate the session, the connection to the remote machine is immediately killed and I have to retry. I believe that I have traced the issue back to this bug report, where the OP explains that the issue is caused by something called ConsoleKit. They then say that (emphasis mine):

The same script works fine if sshd is compiled without consolekit.patch

What does this mean, and how do I go about doing it? I have tried using versions of OpenSSH (sshd on the server) from as far back as v5.0 in hopes that this faulty code won't be included, but it still has this issue. So, I'm hoping that I can compile it myself without including this patch to figure out what's going on.

I don't see any aptly-named patch files or build configuration options, so I'm really not sure where to begin.

7
  • That bug report is about an Ubuntu-specific version of the ssh server program sshd. In other words, this is about the ssh software no the remote system you are connecting to, not the local system that you're connecting from. Is the remote system Ubuntu? Are you trying different versions of sshd on the remote system? Are you able to update the sshd program on the remote system? You say you've tried different versions of OpenSSH, but what _specifically did you do here? – Kenster Sep 3 '15 at 17:59
  • I understand that this is about the server; I was testing versions of sshd. Both the client and the server are running recent versions of Ubuntu. I have updated the question to reflect this clarification (the tags already explain this) – Wasabi Fan Sep 4 '15 at 1:55
  • To test older versions, I would download a specific version of their source code, run./configure, make and sudo make install. – Wasabi Fan Sep 4 '15 at 1:56
  • Where are you downloading this source code from? – Kenster Sep 4 '15 at 1:57
  • I was getting it from what appears to be their official source mirror: ftp3.usa.openbsd.org/pub/OpenBSD/OpenSSH/portable – Wasabi Fan Sep 4 '15 at 2:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.