11

Just moved to Windows 10, love the new look, issue is my NAS is Headless and I use a HDMI emulator so as to activate the display when I connect to it locally/remotely via Chrome Remote Desktop.

The problem is that this worked fine for Windows 7 when connecting to the headless gigabyte brix via chrome remote desktop.

Now there is an additional problem, if I don't add a physical mouse to the brix, when I connect via Chrome Remote Desktop, I cannot see the mouse pointer.

My Query: Is there a software based solution so Windows does not see my brix as a touch screen and hence not show a pointer

OR

Is there a compact hardware based solution something like this which I used for the HDMI solution

3
  • Even a workaround that involves double clicking a shortcut that runs/fixes this, every time I remote into the machine , as a workaround, is welcomed!
    – Mad Max
    Aug 25, 2015 at 16:07
  • Buy the cheapest wireless mouse you can and leave it plugged in? ;p
    – Journeyman Geek
    Nov 9, 2015 at 4:29
  • Not entirely sure if a wireless mouse dongle would work. It is a good idea though. Better than having the wired mouse(like I do) taking up as much space as my gigabyte brix!
    – Mad Max
    Nov 9, 2015 at 12:38

11 Answers 11

13

This is a known bug. A quick workaround (that you'll have to repeat each time you connect) is to click, hold, and drag the "Your desktop is currently shared" notification at the bottom of the screen. The mouse pointer will appear (but note that it won't change appearance when you hover over text or links etc).

1
  • Yes, this is a great workaround! Thanks for sharing, this saved me a ton of time! 🙌
    – janniks
    Jul 30, 2018 at 8:13
9

A solution I've come across is to go to Settings -> Ease of Access -> Mouse and enable Mouse Keys (move the mouse with the numpad). This enables the pointer and still allows the mouse to control it.

2
  • Unfortunately this did not work for me! Thank you for taking the time to reply though!
    – Mad Max
    Nov 4, 2015 at 8:15
  • This did work for me, thank you for the suggestion!
    – pinglock
    Dec 29, 2020 at 21:43
2

I just ran into this problem (also Win10). Awkwardly find your way into the Control Panel > Devices > Mouse > Pointers (tab) and uncheck Enable Pointer Shadow.

That fixed it for me.

1
  • Are you sure you're talking about the same issue as the question?
    – fixer1234
    Oct 14, 2016 at 21:50
1

I managed to get it working by disabling "Hide pointer while typing".

the relevent settings window as an image

PS: I do not know how this works for me

0

This link solved it for me - it suggests that if a mouse is plugged in at boot time, it works. Kind of inconvenient to plug in a mouse each time you reboot. But took care of it for me. Link

1
  • Not ideal, but thank you for sharing! Hope someone comes up with a registry fix for Windows 10 or CRD pushes an update fixing this!
    – Mad Max
    Nov 9, 2015 at 12:39
0

I have this issue when I remote into a machine without an attached mouse. I find that the mouse pointer is still active but you cannot see it.

If I go to Mouse Properties under Control Panel on the remotes machine the mouse will reappear for the reminder of the session. Not ideal but will work.

0
0

I know this is really late but maybe this could help someone else. I was able to fix my issue with this with enabling "display pointer trails". Its a little annoying to look at if you don't like that but it works!

0

Find a USB dongle from a wireless mouse. It could be a broken mouse or you could just buy the cheapest wireless mouse you can find. They cost like 2-3$. You just need the dongle, no need for the mouse itself. Plug the dongle and leave it there, the computer will detect a mouse and you will have a cursor when you use Remote Desktop. Most modern wireless mice have super small dongles and they don't get in the way and you probably have lots of USB ports, so I guess it won't be a problem to keep it plugged in at all times.

0

I got it to work my going to mouse pointer settings and checking the allow mouse pointer trail. This will make a long trail of the pointer but you can lower that underneath the check box and it will look normal!

0

I found that I could activate the mouse appearance by opening any window, then pressing alt-space to bring up the min/max/move/close menu. If I then clicked m for move it would activate the window movement cursor, which was visible.

At that point I could just click out or press escape and voila, I had a working cursor for the rest of the session.

A bit annoying but it's quick.

-1

I solved the problem by disabling the tablet mode in Win10. Apparently, windows thinks that you are using a tablet when the mouse is not connected. I go into control panel/system/tablet mode/use desktop mode, and sign back in the system. The mouse pointer reappears.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .