How do I delete an unwanted entry in AutoComplete in Microsoft Edge? I have tried everything including highlighting with the down arrows and nothing works.


I found out how to delete ALL entries in AutoComplete but not to delete only one.

Go to "settings" "advanced" and choose delete passwords. It gets rid of everything and then you can re-enter the correct ones again. If anyone can figure out how to delete only one, please let me know.


To delete an individual entry it is almost the same process as in chrome. Settings, View Advanced and then Manage my saved passwords. From here you can delete individual entries.

  • 1
    Tried it and it doesn't work. – Marge Sep 26 '15 at 13:35

protected by Community Sep 27 '15 at 20:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.