3

After Upgrading 2 of my PCs (same LAN network) to Windows 10 (coming from Win8.1) I tried to set up my old Remote Configurations.

When I connect via RDP (mstsc.exe) I'm getting the active session of the other PC (as I was used to in Win8.1), I see the desktop and after that, I immediately get disconnected with an Error Message. Meanwhile, I can see the other PC (which I am connecting to via RDP) doing an "auto" login which is the reason I'm getting disconnected in the RDP session.

Sadly my System is in German and I can try to translate the error message:

The remote desktop session has closed.

The connection has been disconnected because another user has connected to the remote machine" 

(something like this)

I successfully managed to use a tool to configure multiple logins of the same user, which isn't the solution I'm looking for because I definitely want to get the "active" session of the user I am logged in with.

Any help is appreciated.

//Edit: It doesn't matter if I'm connecting from PC1 to PC2 or vice versa... Still same behaviour

//Edit2: PC1 is Windows 10 Education N, PC2 is Windows 10 Pro N

//Edit3: Something to add: I have no passwords set on my Windows Accounts and I enabled the Option to allow Connections without Passwords (secpol.msc -> Local Policies -> Security Options -> Accounts: Limit local account use of blank passwords to console logon only -> set to disabled ... As I was playing around some more I thought "let's try setting a password and retry rdp ..." Finally, the remote machine is not doing auto logins anymore. Anyway, that's not the solution I was looking for. I don't want to be forced to use passwords since it worked that way since I can remember using Remote Desktop.

Any ideas on how to get RDP without using passwords working again?

5 Answers 5

0

I can verify this bug. Win 10 PCs without password on local account and disabled "Limit local account use of blank passwords to console logon only", within a second or so I get disconnected by the local machine which seems to auto login by itself when a connect with remote desktop.

I have "fixed" it using VNC and TeamViewe while I wait for a bugfix from Microsoft. Have you heard if there is any prefix or fix yet?

4
  • Sadly I haven't heard about a real fix yet. I'll let u know here and at the technet page once i know about how to fix this. Would be nice if you could also tell me if you manage to find a solution other than 3rd party tools :)
    – sobrino
    Sep 20, 2015 at 13:13
  • If you first do a Ctrl-Alt-Delete and choose "Switch user", after that you can remote access that computer. So, if we can do that remotely (get a Win 10 into that "Swtich user mode"), then we can also remote access it.
    – raffe
    Sep 20, 2015 at 20:54
  • I tried tsdiscon, but it don't seem to be the same as "Swtich user command"
    – raffe
    Sep 20, 2015 at 20:59
  • Thx for letting me know. I am going to try this later and maybe do a bit of research myself about remote switching users.
    – sobrino
    Sep 21, 2015 at 8:23
0

Method 1. I have success by SignOut from the PC itself first. Then remote login from another PC or smartphone. That way the desktop won't auto login itself and kick the remote session.

I'm not sure why but I guess the PC won't support continuous login session.

Method 2. Previously I don't have password to login for the user. After setting one, I'm able to login without being kicked out.

1
  • I am pretty sure I tryed that when I first encountered the problem. If this method is working now, they maybe have changed something since. Thx for your feedback! Still waiting for a real fix tho.
    – sobrino
    Oct 15, 2015 at 12:29
0

I can verify this problem as well. The closest solution from Microsoft I could find is: this.

EDIT 03 August 2016: I edit my post to say that the issue seems to be solved with the Windows 10 Anniversary Update.

0

Download autologon from here.

Unpack it. Then open command prompt as administrator, navigate to the unpacked folder and do autologon /delete

This should remove all autologons.

7
  • I got an Error Message saying "Usage: autologon <username> <domain> <password>"
    – sobrino
    Aug 26, 2015 at 16:54
  • I have added some informations to the question (Edit 3).
    – sobrino
    Aug 26, 2015 at 17:10
  • For Edit 3 - you can store the password in the RDP file. Open MSTSC.exe -> Show Options -> enter computer / username -> save as... -> Connect -> Enter user/pwd and tick "Remember my creds". Detailed steps: nextofwindows.com/…
    – cdavid
    Aug 26, 2015 at 23:30
  • For your first error -> autologon /delete works on my machine - it says AutoAdminLogon disabled. Maybe it's related to you not having a password?
    – cdavid
    Aug 26, 2015 at 23:31
  • Thanks for your reply. I know that passwords can be stored in the rdp file. I wouldn't mind using this for the remote connections, but i don't want to use passwords on my local machine. And as i want to work on the same session (not at the same time), I can't just use another user for that. I reported that issue to M$ ... let's see what they come up with.
    – sobrino
    Aug 27, 2015 at 6:42
0

I tried this

Prepare computers for remote commands

  1. Read first: How to Run PowerShell Commands on Remote Computers

  2. Do this on both computers (be sure you know what TrustedHosts will do! Maybe you want to replace the * with a comma-separated list of IP addresses or computer names).

  3. open a PowerShell window as Administrator and run this

Enable-PSRemoting -Force 
Set-Item wsman:\localhost\client\trustedhosts * 
Restart-Service WinRM

Enable-PSRemoting problems?

If you get problems with Enable-PSRemoting -Force that say something like "...firewall exception will not work since one of the network connection types on this machine is set to Public...", maybe with a VPN connection:

  1. Read How to Set Network Location to Private, Public, or Domain in Windows 10
  2. Check with
Get-NetConnectionProfile
  1. Run something like this (but with your network name)
Set-NetConnectionProfile -Name "Unidentified network" -NetworkCategory Private

Test remote commands

Open a PowerShell window as Administrator and run this on the computer that will connect with Remote Desktop to 192.168.0.100 (or COMPUTERNAME)

Test-WsMan 192.168.0.100
Invoke-Command -ComputerName 192.168.0.100 -ScriptBlock { explorer } -credential admin
Invoke-Command -ComputerName 192.168.0.100 -ScriptBlock { dir } -credential admin

That works (File Explorer opens, dir show content on remote PC). But if I try:

Invoke-Command -ComputerName 192.168.0.100 -ScriptBlock { tsdiscon } -credential admin
Invoke-Command -ComputerName 192.168.0.100 -ScriptBlock {  c:\windows\system32\tsdiscon.exe  } -credential admin

Nothing happens :( But maybe you will find something...

2
  • Maybe technet.microsoft.com/en-us/library/hh849747.aspx but I need to go, so I don't have time to test right now...
    – raffe
    Sep 21, 2015 at 14:23
  • I tried -ScriptBlock { query session } and then -ScriptBlock { tsdiscon 1 /v }. The session gets disconnected, but it auto login again.
    – raffe
    Sep 21, 2015 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.