33

Whenever I select a section of text in MS Word, it automatically alters the selection to add or remove whitespace depending on the context of the selection.

As a developer that works with plain text all day, I expect that when I place my curser over a character and click/drag backwards to select a group of text, that the place I initially clicked will be the end of the selection. However, Word seems to insist that in some cases it must also select some trailing spaces and/or newline characters.

How can I simply turn off all "smart" selection behavior?

I have already deselected "select entire word when selecting text" and while this is helpful, it still does not solve the problem of automatically selecting the newlines and spaces after the word. (e.g. if I click the end of a sentence and drag backwards a couple of lines, it will expand the selection to include the newline at the end of the sentence. likewise if I select a word and delete it, it deletes an additional space.)

I am using MS Word 2016 but this applies to all versions over the last 10-15 years or so.

  • Then what you need is Use smart paragraph selection, turn that off for the newline at the end. – MC10 Aug 25 '15 at 20:47
  • 1
    Does anyone understand the rationale behind Microsoft's decision to make this awkward behavior the default? I've been trying to think of a use case where this behavior would actually be helpful. Nothing comes to mind, though. – antred Feb 10 at 10:51
  • 1
    Stupid word and it's stupid smaaart selection for imbeciles, which, by the way, will have even more trouble with it, argggh, sorry. – AgentFire Apr 3 at 13:12
  • 1
    @antred I think this kind of idiotic behaviour is the default on Windows, because apparently Microsoft doesn't think its users know how to select text, I guess. Another MS UX fail. Selecting by words is already so simple with a double-click and drag anyway, there's no justification for this nonsense. – devios1 May 15 at 17:26
28

Go to FileOptionsAdvanced → under Editing options, uncheck

☑ When selecting, automatically select entire word

and

☑ Use smart paragraph selection

Screenshot

Edit:

You can also disable the settings for copy and pasting. Scroll down to Cut, copy, and paste and click Settings... Then uncheck:

☑ Adjust sentence and word spacing automatically

and

☑ Adjust paragraph spacing on paste

More options

  • I also unchecked the following to disable the space adjusting on delete and copy/paste: "adjust sentence and word spacing automatically" and "adjust paragraph spacing on paste" – Andrew Marshall Aug 25 '15 at 20:56
  • @AndrewMarshall Where are these settings under? I can't find them in Word 2013 but I'm still looking. You can edit it in to the answer if you'd like. – MC10 Aug 25 '15 at 21:00
  • 1
    I am using Word 2016 on Mac OS X. Here you can find these settings under word --> preferences --> edit --> cut and paste options --> settings – Andrew Marshall Aug 26 '15 at 4:19
  • @AndrewMarshall Ah, thanks. I've edited the info into the post. – MC10 Aug 26 '15 at 12:59
  • Does PowerPoint allow one to disable its equivalent feature? – Andy Terra Mar 28 '17 at 2:33
1

You can also hold Shift+Ctrl when selecting text, and this feature will be disabled

  • no, not working – Ignas Mar 25 at 23:02
1

To disable this "smart selection" for Outlook for Mac - and probably for the whole Microsoft Office suite for macOS - you have to install Microsoft Word and uncheck

Word -> Preferences -> Edit -> Select entire word when selecting text 
  • 1
    this does not work anymore :( – daniel.sedlacek Apr 24 at 11:38
  • 1
    This un-feature constantly gets in my way. I disabled the option in Word, but it is still happening in Outlook and Outlook doesn't have the option in its preferences to disable! – devios1 May 15 at 17:21
1

I would have posted this as a comment, but I don't have sufficient reputation :(

As @daniel.sedlacek stated, While in Word For Mac 2019, go to the menu bar, Click on Word -> Preferences -> Edit.

Uncheck Select entire word when selecting text.

Also uncheck Include paragraph mark when selecting paragraphs.

^This will put an end to Word selecting the extra space at the end of a paragraph when you highlight it going right-to-left.

enter image description here

Alternatively, you could highlight the paragraph going left-to-right, and it will obey your stopping point.

0

I have the same problem

  1. When selecting a paragraph, ensure that the selection end at the last character on the paragraph (not selecting a virtual space after the paragraph), or
  2. When you paste, click paste option icon (appears under the pasted text) and select the last option (keep text only)

good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.