1

I have a networked device (an old motion controller) that I have connected to my network via a switch. My PC is connected to the same switch. This configuration works as expected and I can ping and open TCP connections to the motion controller.

However, if I swap the switch with some other models then I can no longer ping/access the device. I've tried two other (otherwise working) switches and the device doesn't work with either. Generally speaking isn't a switch just a switch? What differences can I look for between the switches to troubleshoot this?

The switches I've tried (all gigabit) are:

Working:
  D-Link DGS-1008D 
  TP-Link TL-SG1008D 

Not working:
  TP-Link TL-SG1016D 
  HP ProCurve 2708 J4898A 
  • what is the device in question? – pete Aug 26 '15 at 1:36
  • This piece of... @pete. – 101 Aug 26 '15 at 1:44
  • do you have a simple hub you can place between the motion controller and the switch(es)? this would allow you capture packets, and also determine if there isn't some form of hardware incompatibility (eg, power-over-ethernet; energy-efficient-eth, etc...) – pete Aug 26 '15 at 2:05
  • possibly a helpful note for other readers, the controller uses modbus/TCP; i'm quite unfamiliar, but i did see one mention of occasional network issues involving message timing. – pete Aug 26 '15 at 2:14
  • Unfortunately not @pete. I might have a look with wireshark... – 101 Aug 26 '15 at 2:27
3

The most likely difference is speed and duplex negotiation. You might find the device is acting as 10 megabits half duplex and your gigabit switches can't handle this.

(Your switches rule out the possibilities of it being a VLAN issue or PoE issue)

  • Thanks, I know the device certainly doesn't connect at gigabit speeds, so that could well be it. Is there a way to check that from a PC if the switches are unmanaged? – 101 Aug 26 '15 at 2:36
  • Not really, but - based on the specs you provided - your switches are all unmanaged. – davidgo Aug 26 '15 at 2:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.