42

I successfully made a live USB of the Kali Linux.

When I boot from the USB it gives an option to install. I clicked on that option. At one point it was detecting and mounting CD-ROM drives. As I have no CD-drive or any ROM-drive on my laptop, it gives an error

Can't mount and detect CD-ROM drives.

I tried the "live something" option that takes me directly to Kali Linux and it loads successfully but I can't install it permanently. I want to install it so I won't have to waste my time plugging and unplugging the USB.

How to get past the CD-ROM detection and make the installation finish correctly?

  • 1. How did you create USB installation? I did it using program unetbootin many times and never had any problems. It works with Kali 2.0 without any problems. 2. Did you try to use expert install option? Usually in expert install mode you can skip certain steps by moving to next one in the menu/installation agenda. – mnmnc Aug 26 '15 at 9:56
  • i did it with rufus there is no probem in making usb but it gives that error – Usman Zia Malik Aug 26 '15 at 14:13
  • See the point no 2 in my previous comment. Kali is based on Debian so it has the same installer. Try to use expert install and skip CDROM step. – mnmnc Aug 26 '15 at 14:33
53

You could resolve the error by repeating the steps :

Run the installer.

Open a shell (ALT + F2).

Create the directory cdrom directly on the root of the file system:

mkdir /cdrom

Note : If you got problems making the directory /cdrom, disable the CD-rom player in BIOS or disconnect the cable

Mount the USB as if it is a CD-ROM:

mount -t vfat /dev/sdb1 /cdrom

Where sdb1 is your USB device.

You could carry on installation now

After executing mount -t vfat /dev/sdb1 /cdrom, cd into the /cdrom directory and do an ls to see if the files are there. Then press ALT-F1 to go back, continue and re-select "detect CDROM"

Source :ubuntu and debian

Another layman solution was :

when the Window shows CDROM couldn't be mounted ,

  1. Unplug your USB from system and re insert it

  2. wait for mount/ detection (usb LED glow)

  3. Hit Continue

You could do what I did. Hit escape, type install, hit enter, skip CD drive.

  • Im a new guy and cant understand that – Usman Zia Malik Aug 26 '15 at 14:13
  • 5
    Layman solution works – AdHominem Jul 7 '16 at 19:29
  • 2
    Unplugging the usb and putting it back in worked for me. Thanks! – Mastro Sep 7 '16 at 3:02
  • 2
    after executing mount -t vfat /dev/sdb1 /cdrom cd into the /cdrom directory and do a ls to see if the files are there. Then press ALT-F1 to go back, continue and reselect "detect CDROM" – Daniel F Oct 10 '16 at 20:17
  • 1
    For those where this doesn't work: go to "Execute Shell" if trying to run Kali linux and type in dmesg. You may be getting errors but it's a start to debugging why no one's solution will work. In my case, it may actually be a kernel bug, or I've put the wrong installation on. I'm not sure, as it takes forever to download the distro from their site but hey, it may just be that. – Paul Carlton Oct 21 '16 at 21:31
26

If you use Rufus (v 2.x) to burn the ISO to USB drive, make sure the option is "DD Image" in "Create a bootable disk using". Not sure if Unetbootin offers the same option. If image is copied using this method, you don't need to go to terminal and manually mount it.

With Rufus (v 3.x), you can not explicitly choose DD mode. IF the ISO is hybrid or has DD mode, Rufus will prompt you to choose ISO or DD mode AFTER clicking start button.

  • 2
    the option in rufus worked for me. thanks – E2Busy Dec 14 '16 at 21:12
  • I couldn't find this option in Rufus 3.0. I used version 2.18 which has it. This option worked for me as I couldn't disable the non-existent CDROM through the bios. – 11chubby11 Jun 12 '18 at 4:33
  • @11chubby11, answer updated for Rufus v3. It will depend on the ISO file. Rufus will prompt you accordingly. This is a change from Rufus v2 to v3. Previously it allowed you to explicitly choose DD mode. – anonymous coward Jun 13 '18 at 18:12
  • 1
    This is a much simpler solution than the accepted answer. Thank you! – Mako-Wish Oct 23 '18 at 23:12
  • Neither the mounting of the device with the types vfat, iso9660, nor a re-inserting of the USB-Device has worked for me. But your solution for Rufus 3.x did it...! – bambam2174 Dec 29 '18 at 0:21
4

I tried all the answers here and more google results, but none worked. I eventually figured it out, the issue is the file format is not vfat, but iso9660.

When you get the CDROM not found error follow these steps:

Enter a shell (CTRL+Alt+F2)

Note: Kali told me to press (Alt+F2), but this didn't work

Get a list of devices with blkid:

~ # blkid
/dev/sdc1: UUID="2018-04-12-12-04-16-00" LABEL="Kali Live" TYPE="iso9660" PARTUUID="81c5e086-01"

Note: I have shortened my list to the relevant row. Also you can see the storage type is iso9660, not vfat

Mount the Kali CD with the mount command:

~ # mount -t iso9660 /dev/sdc1 /cdrom

Check the contents of /cdrom are as expected:

~ # ls /cdrom
autorun.inf     efi             g2ldr.mbr       md5sum.txt      win32-loader.ini
boot            efi.img         install         pool
debian          firmware        isolinux        setup.exe
dists           g2ldr           live            tools

Switch back to the installer (CTRL+Alt+F5)

Note: Kali told me to press (Alt+F1), but this didn't work. I tried F1 through to F5 until I found the correct combination

From the menu tell it to mount the CDROM, if asked choose /dev/sdc1 and /cdrom. I know we have already mounted the drive, but for some reason this step didn't work previously, but worked fine after following the previous steps.

The install will now continue as normal.

  • This solution works for me, thanks! My environment is Kali 2018.3/Rufus 3/DD Image. – Icyblade Aug 30 '18 at 13:44
2

checked the issue myself right now: it's a WAY MORE simple - use "Graphical install". It seems to rise additional hw-related services and it works just fine! Also - if you're using 2 flash drives - plug OFF the drive you're about to install it to, boot it in GUI - and then plug the target drive.

  • 1
    Don't think that's the solution. I have the CD-ROM issue and I only use the Graphical Install option. – Marc Mar 31 '18 at 12:30
  • The DD Image option above worked for me. – Marc Mar 31 '18 at 12:42
0

I have tried every single answer but none of them worked. After some more searching online I found an answer that worked for me.

It is fairly simple but just download Win32 Disk Imager. Click on the folder icon and change the filter to all files or . Then select your .ISO file, select your device and click on write.

After doing this I inserted my USB (3.0) into a USB 2.0 port on my computer. When I booted to my USB it worked instantly.

protected by Community Sep 13 '15 at 5:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.