Trying to create Kali Linux live USB persistance. Split the usb like this:

|| first part FAT for data || second part FAT for LINUX || third part for persistance||

Then set "bootable" flag in gparted on /dev/sdb2

Format: mkfs.vfat -n linux /dev/sdb2

Then trying to copy kali linux files, like this:

`dd if=kali-linux-1.0.9a-amd64.iso of=/dev/sdb2 bs=512k`

Now, I reboot my laptop, select Flash Drive as boot-able device, and have this:

    grub error: File not found...
    grub entering rescue mode
    grub rescue>

Then, I tried out things mentioned in the following links:




and nothing helps!

    grub rescue> ls
    hd0, (hd0,msdos3), (hd0,msdos1), (hd0,msdos2), (hd1,msdos4), (hd1,msdos3), (hd1,msdos1), (hd1,msdos2), hd1
    grub rescue> set

I have already spent 3 days to solve this problem and can't find a solution.

P.S. fdisk shows for /dev/sdb2

Command (m for help): p

Disk /dev/sdb2: 4294 MB, 4294967296 bytes
193 heads, 32 sectors/track, 1358 cylinders, total 8388608 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0a9a1b1a

     Device Boot      Start         End      Blocks   Id  System
/dev/sdb2p1   *          64     6324223     3162080   17  Hidden HPFS/NTFS
/dev/sdb2p2         6324224     6485375       80576    1  FAT12

Are it's normal partition table for Kali Linux?

  • I partly solve the problem by reformatting partition /dev/sdb2 and reinstall grub on it. Now. I have new problem. Can't start kali linux from grub. Aug 27, 2015 at 9:21

2 Answers 2


You could solve your problem by following these steps :

Find out which devices are available by typing ls

Set to the correct value :

set prefix=(hd0,1)/grub
set root=(hd0,1)
insmod normal

The above commands will get you out of the rescue mode to the normal terminal mode. After the above commands you can go ahead and start the rest of the settings.

insmod linux 
linux /vmlinuz root=/dev/sdXY ro 

If the above command doesnt work try this :

linux /boot/vmlinuz-3.2.0-14-generic root=/dev/sda1 ro

Additionally dont forget to update your grub

Update the GRUB config file.:

sudo update-grub

Reinstallation of Grub on the device:

sudo grub-install /dev/sdX

hope it helps

  • Unfortunatly it didn't help. I found, that: ls (hd0, msdos1) is my first partition with media data ls (hd0, msdos2) didn't show anything. All other "partitions" shows "unknown filesystem" After set prefix=(hd0,msdos2)/grub and root=(hd0,msdos2) command insmod normal shows "file not found". Any other combinations of prefix, root, and path to grub didn't help. Aug 26, 2015 at 14:52
  • For me this does help in fixing grub and getting it to boot, but then when I reboot I get the same error :(
    – Cas
    Aug 27, 2016 at 17:00
  • I got into rescue mode after updating Kali from the GUI. This is terrible! Linux feels so fragile! When doing the insmod normal, I get a file '/grub/i368-pc/normal.mod' not found. If anyone has any ideas flying, let me know, because I have no idea what I am doing... Jul 31, 2019 at 9:07

I encountered same problem too after deleting my kali-linux partion from Windows disk management. I was able to solve the problems though and I think you can use this as well:

  1. You must have a minimum of 4G flash drive.

  2. Go to https://sourceforge.net/projects/boot-repair-cd/files/latest/download and download boot repair iso file (780MB in size).

  3. Download Rufus ISO burner https://rufus.ie/ and install (1.1MB in size or above). If you don't know how to use Rufus, search it on the Internet, then burn the boot repair ISO on your flash drive,

  4. Make sure your OC is turned off, plug in your flash drive, power up your PC and press F9 for boot option. Make sure you boot from USB.

  5. After booting from USB the repair will take over from there with little question from you. It's as easy as that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .