0

My touchpad (Elan Smart-Pad) on my Toshiba Satellite PSPRDU-00C003B is only working on Windows now. It had been working with both Windows 10 and Ubuntu but now it only works when running windows. It doesn't work when anything else boots including: windows advance start up/recovery options, installed ubuntu, live ubuntu or fedora, windows 8 installer.

It was working with Ubuntu after 10 was installed I think. I noticed the touchpad stopped working while installing Wine on Ubuntu. I've tried FN + F5 toggle it on/off (toggling works on windows) (including during grub as suggested by a post) (bios is set to use fn for special instead of default fn for F[1-12]), tapping corners (don't think that is even a feature on this machine), and lots of stuff from askubuntu.

Windows touchpad driver: ETDWare PS/2_SMBus-X64 11.8.22_WHQL. Was installed while Running 8.1.

Laptop also has a touch screen. Works touch like on windows as expected. I think it was working more mouse like than normal on ubuntu but I don't actively use it to compare before and after.

USB wireless mouse works fine all around.

OS history: Bought refurbished; Wiped hardrive and clean installed 8.1 home with oem key. Installed Ubuntu 15.4 Gnome along side. Upgraded to 8.1 pro with dreamspark key. Upgraded to 10 pro with no immediate issues. installed wine and (coincidentally?) noticed the problem.

On ubuntu synclient used to always report off=2 and couldn't be changed to 0 and now after doing other stuff I just get no driver detected message.

Not sure if its related but I seem to be frozen out of most bios (Toshiba setup utility bios v2.0) settings for some reason. secure boot had been off to install ubuntu and shortly before it stopped working I had turned it back on. While trouble shooting I turned it back off and now I seem to be unable to change most settings in bios. I'm not given an option to input a password to make changes, I just can't. The options are grayed out and not selectable.

update

For a small bit it stopped working in windows also. I powered off and on and it didn't work. restarted a few more times and it randomly started working. The first time I tried starting there was some weird static on the bottom 4th of the screen during boot up. I tried to make it appear again but restarting didn't produce it. Touch pad still didn't work. I powered off and on again, didn't get it and touchpad worked. I think it might be a hardware issue :(. Still under warranty so might get it checked out.

  • maybe you got a firmware update for the mouse bundled with Win10 upgrade. and now that "fixed(broke)" it for you in Linux. – Piotr Kula Aug 26 '15 at 8:26
  • @ppumkin note its also broke for windows special start up and windows 8.1 installer. I could try the 10 installer next week when I return to college. Don't have the bandwidth to download at home and to continue living. Windows 10 doesn't really tell you what it downloads :( – Old Badman Grey Aug 26 '15 at 8:31
  • OH right. Yea Windows 10 seems to be coming with allot of surprises... I can only recommend to try and download the firmware or driver form the laptop site and try and use that or flash again with older one. – Piotr Kula Aug 26 '15 at 8:33
0

Just wait for the problem to fix itself. It started working again after a random Windows update. I had to reinstall Ubuntu to restore full functionality because of things I did to try fixing it. I assume it would work with windows instillation media as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.