2

I've been trying to make WOL work after full shutdown and I got it working. Magic Packet is being sent to broadcast by router and PC boots up even if it's fully shut down (here is how it's done in case that can provide any useful info. link. Alas, there is a problem. When PC is launched with Magic Packet, upon launch and loggin in into Windows:

  • Network icon is shown with red cross
  • In device manager adaptor got yellow triangle with ! near it
  • In Properties, Device state it says "can't launch device, code 10"
  • In event log, under errors, source e1cexpress, it says "Intel(R) 82579V Gigabit Network Connection PROBLEM: Unable to start the network adapter.", event code 24

It won't work unless I disable and re-enable device in device manager and that's kind of defeats the whole point. I'm going to travel for a month and I'd like to have access to my PC from abroad. Therefore, I set up a way to launch my pc via Internet and for TeamViewer to be launched upon windows boot so I can log into my pc via TeamViewer and do what I need. Whole TeamViewer setup works, but only if I boot PC normally, not via WOL method. A thing to note is, that when I boot my PC normally, I get one TeamViewer ID, but when I boot via WOL, I get a different one (it's always same when I use WOL method).

If anyone got any ideas about what's causing this and how to make it work, please let me know. I'm leaving soon and I desperately need this setup working.

Info:

  • OS: Win 7 x64
  • MB: Asus Rampage IV Extreme
  • Network adaptor: Intel 82579V Gigabit Network Connection
  • Driver: Latest from Intel website
1

So I kept experimenting to find a solution. I tried different settings in BIOS etc. Nothing worked. Then I remembered my MB got 2 BIOS'. So I switched to 2nd (which was stock version 4602), enabled power on by PCIe in APM, shut down pc fully and tried waking it up as usual. And oh, magic happened and everything worked as it's supposed to.

I then proceeded to eliminate possibility of wrongly configured BIOS1 by reverting settings to defaults and even removing battery. Still didn’t work. At this point, it was obvious that the cause is within this revision of BIOS (4901). I then decided to flash lower revision of BIOS and see at which one it still works. I ended up with 4802, which last one before 4901. Conclusion: If you encounter same problem with this MB, simply downgrade your BIOS to revision 4802, either via:

  1. Use BIOS flashback (put needed .CAP onto flash drive, rename it to R4E.CAP, put flash stick into ROG connect usb port, hold ROG connect button for like 3 seconds )
  2. If your BIOS2 revision < 4802, go to BIOS2->Tools->BIOS Flashback, select copy BIOS2 to BIOS1, then switch back to BIOS1 and upgrade it to 4802. Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.