0

First of all, I am using these things:

  • Windows 7 host
  • Ubuntu 14.04 guest (just set this up)
  • VirtualBox 5.0.2

Where I'm at now

I am having some issues with my networking settings. Everything is at default right now (attached to NAT and, yes, "cable connected" is checked). I can successfully ping IPs and domain names to the outside world from the guest. E.g., commands like this succeed:

ping 8.8.8.8

ping google.com

et cetera, both successfully getting back packets, so I must have some kind of connection and DNS service.

However, I cannot browse the internet or things like this do not work:

curl google.com

telnet google.com 80

et cetera, all fail.

Steps I've taken so far

I should note that my networking issues started when I moved onto my university campus and started using its network. Before I was on campus, all of my virtual machines (a variety of guest OSes) had internet fine and dandy. This is when my problems start, but I cannot guarantee that this is related to my issue; several of my peers use VirtualBox with the same host and guest setup as I do on campus network without issues.

I spent a lot of time yesterday trying to fix this issue. I decided to uninstall and reinstall VirtualBox and set up a brand new guest machine.

Initially, pinging the IP address worked but DNS lookup was not working, so I followed the instructions in this thread and ran this in the host:

VBoxManage modifyvm "My guest VM name" --natdnshostresolver1 on

and then DNS service started working in the guest and I could do things like ping superuser.com successfully.
(Side question: is this off by default?)

This guy (askubuntu forums) had a similar issue as I did (his title: "I can Ping, Dig, but I can't browse", and he is using a bridged adapter). The answerer suggests using WireShark (on host) to figure out what is blocking and that it might be a firewall thingy. The dude ultimately fixed his problem but I don't think my problem is similar enough to his for this to work out:

*Thanks for everyone's help, the problem was the avast! firewall, I solved it activating the ICS mode on it's firewall. *

Tried disabling my Windows firewall, but that was really a desperate act and didn't work. Also I have no idea what I would connect ICS to or if this is at all related to the issue. I know almost nothing about networking (except what I learned so far trying to solve this problem). Also, I'm not actually sure the title of my question is correct.

So how do I fix this? All help appreciated, thanks.

Edits:

I should note that campus network requires WPA-2 Enterprise username/password authentication. Switching to bridged mode (as suggested by Frank in his comment below) allowed me to authenticate from within the guest, no problems. Now, when creating a new guest machine, the Ubuntu install likes to be connected to the internet (but I can't authenticate during install) so I'd still like to find a way to NAT if possible (I still want to leave the question open, but maybe it's more appropriate for me to open a new one for this issue? Not sure, sorry new here)

2
  • 1
    if bridged networking is fine with you, it will probalby fix the browse, thought no gaurentees. you should not need ICS, and I would certianly not complicate matters further. this should be working for you, so if it isn't you want to fix the problem rather than engineer around it. – Frank Thomas Aug 26 '15 at 19:09
  • Huh, this seems to work (could have sworn I tried this), but with some caveats (I'll edit my question to include the details of this). Thank you for your help. – NoobScrub Aug 26 '15 at 19:23
0

If you can ping, and resolve DNS, it implies you have connectivity. You don't mention specifically how curl or telnet fail. Any error messages? Off hand, the only thing I can think of is that "ping" and DNS are UDP protocols, while browsing, telnet, and curl are TCP. Perhaps your campus network has odd rules locking down TCP connections, but allowing UDP?

If your host OS can browse successfully, then the problem is definitely in the VirtualBox interface with the host not working correctly.

0

I'm sorry to necro-bump this thread, but if anyone is having same issues, try to uninstall redirectors such as ProxyCap, proxifier, etc. VirtualBox NAT doesn't work with them and you won't find any error message in the logs and you won't see anything in the pcap file if you try to trace VirtualBox networking. Disabling ProxyCap is not enough, it has to be uninstalled or you need to reset your network config with "netsh winsock reset" but ProxyCap won't work for you anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.