9

I've just installed Windows 10. Ctrl+Win+Right doesn't work to change virtual desktops. Ctrl+Win+Left works fine, as does Ctrl+Win+NumpadRight.

Oh, and Ctrl+Alt+Right works to turn the screen on its side.

I don't know how to debug this at all. Any ideas?

  • Saw your comment that your laptop keyboard was causing the trouble. That really stinks. Would you mind ratting out which PC manufacturer (and model) it was? – ruffin Dec 7 '16 at 13:42
8

This is key jamming. You'll need to upgrade to a higher-quality keyboard.

  • Most keyboards use matrix circuits for keypress detection and cannot detect simultaneous presses of certain combinations of three keys. The specific combinations that cannot be detected depend on the keyboard model. In these situations, the keyboard will not register the keypress. On your keyboard, the matrix as laid out inside your keyboard is unable to handle the Ctrl+Win+Right Arrow combination.

  • More expensive keyboards generally have better isolation among keys and do not suffer from such jamming. Generally, any keyboard with some degree of "anti-ghosting" should not suffer from this issue. The best keyboards have "n-key rollover" and can handle any number of simultaneous keypresses; these keyboards are generally very expensive and should not be necessary to address this issue. See: Wikipedia article on keyboard rollover.

  • I guess you're right. It's my laptop keyboard, which is a bit of a pain. I tried another keyboard and it works just fine. – wilbo Aug 28 '15 at 20:06
5

Since windows doesn't allow changing keyword shortcuts,
The only option that remains is to map another key on your keyword to WIN key.

I used sharpkeys and re-mapped my RAlt key to WIN key.
Now i can use Ctrl+RAlt+Arrow to move around.

Another option is to use autohotkey.

LCtrl & Left::sendevent {LWin down}{LCtrl down}{Left down}{Lwin up}{LCtrl up}{Left up}
LCtrl & Right::sendevent {LWin down}{LCtrl down}{Right down}{LWin up}{LCtrl up}{Right up}

Create a file with .ahk extention and use the above code.
You will be able to move around with LCtrl + Arrow keys.

I recommend using sharpkeys ( it's much simpler and easier to work with ).

4

I had this same issue with the Left Ctrl+Windows+ / combo not switching Virtual Desktops. A workaround that worked for me is using the right Ctrl key on my laptop's keyboard. Right Ctrl+Windows+ /.

1

It is more likely that the shortcut it not working because at the current time when pressing [CTRL]+[WIN]+[RightArrow] you are not moving to the next virtual desktop because you dont have one active.

Try [CTRL]+[WIN]+[D] this will create a virtual desktop then you can swap with [CTRL]+[WIN]+[Arrow]

You can also push [WIN]+[TAB] to show your desktop in a view that has an option on the bottom to add a new one manually and you can also close them from this page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.