3

I'm trying to set up communication between my guest Windows 7 and host OSX machines. I have virtualbox configured with a vboxnet0 Host-only network with the following settings:

IPv4 Address: 192.168.21.19
IPv4 Network Mask: 255.255.255.0
IPv6 Address:
IPv6 Network Mask Length: 0

and DHCP disabled. I have my Windows 7 vm configured with Adapter 1 as a Bridged Adapter (that works correctly for internet access) and Adapter 2 as the vboxnet0 Host-only Adapter.

On the Windows 7 vm I see two active Local Area Connections, Network 2 (which I assume is the bridged one and looks to be configured correctly) and Unidentified network which I assume is supposed to be the Host-only. I've read a lot about fixing Unidentified network issues but all solutions rely on editing a registry value I do not have. Device manager on the Windows vm shows both adapters as Intel(R) PRO/1000 MT Desktop Adapter which is why I assume I cannot find the correct registry value to edit in order to fix the Unidentified network problem.

ifconfig vboxnet0 on the mac returns:

vboxnet0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 0a:00:27:00:00:00
    inet 192.168.21.19 netmask 0xffffff00 broadcast 192.168.21.255

ipconfig /all on the VM gives

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Pro-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Desktop Adapter #2
   Physical Address. . . . . . . . . : 08-00-27-F1-F3-03
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::5000:42b6:9cff:5d1%13(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.5.209(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 302514215
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-51-B1-EC-08-00-27-E6-26-5D
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Desktop Adapter
   Physical Address. . . . . . . . . : 08-00-27-E6-26-5D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::bdc5:f6fa:e541:cdc8%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 10.0.1.223(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Wednesday, August 26, 2015 4:26:45 PM
   Lease Expires . . . . . . . . . . : Thursday, August 27, 2015 4:26:47 AM
   Default Gateway . . . . . . . . . : 10.0.1.1
   DHCP Server . . . . . . . . . . . : 10.0.1.1
   DHCPv6 IAID . . . . . . . . . . . : 235405351
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-51-B1-EC-08-00-27-E6-26-5D
   DNS Servers . . . . . . . . . . . : 8.8.8.8
                                       4.2.2.2
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{6498E4F3-8CC9-4D50-BB63-F1D6C7FAD40C}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{E6A74B05-7F4F-4D38-AF1B-AC517AF26AA9}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
2

I had a similar Issue, and ended up solving it with a small trick.

  • Go to control panel-> Network and sharing
  • Select the host-only network connection, and go to properties (not details) You'll notice no default gateway is configured.
  • Select Internet Protocol Version 4( for IP4 address) and select Properties again.
  • Click on Advanced button and add a default gateway with the ip of the host in this host-only interface (the one that shows when you execute ifconfig in the host OS).
  • Ok, Ok, Close, Close.

In my case it asked me what kind of network it was( I'm a Windows noob, so selected Home Network and crossed my fingers ). Tried again to connect from host OS and it works.

0

I had to disable Cisco's VPNadmin Service and OpenVPN Service on my host. I did this by running msconfig and disabling these services "on Windows start". Then I rebooted. Finally I had to DISABLE the "VirtualBox Host-Only Network Adapter" in my network connections panel.

If I now need VPN I have to start the services manually - but this is bearable for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.