1

On my Dell Notebook, I recently upgraded my RAM from 8GB to 16GB, and the secondary mSata SSD from 32GB to 512GB. First HD is magnetic. On the SSD, I got Intel Rapid Start and Intel Rapid Storage running in 16GB and 64GB (now invisible) partitions I create after the upgrade.

Now I noticed that some programs somtimes just dont react. Typically, I have them minimized and put them back to normal (visible on screen) by clicking on the task bar. This most often works instantly, but with some programs like notepad++ and lync for business, this can take a few seconde, something like 3-5 seconds. Also, when I want to move a visible window, I sometimes get that delay.

Both is very cumbersome. When I start dragging a window I expect it to move, but here it does not move and only becomes usable after a few seconds, at which point I need to drag the window again.

I (think I) can increase the likelihood of the unwanted behavior by not using the program for a while. I think it is not related to any energy saving of the HD though, since I dont see increase response time when the problematic behavior occurs.

After the update, I have made a SATA FW upgrade (Crucial M550 now at version2) as well as Intel Rapid Storage upgrade to latest version. Windows 8.1 is all patched up.

Also, by now, I typically have task manager open on performance tab to watch the HD response time (for the magnetic drive, SSD shows 0% just about always). I did not notice anything unusual, like peaking response time or active time, when the programs/windows do not respond. CPU also is < 10% used, memory at 5GB/16GB.

So I tried:

  • Task Manager performance tab -> no hint, normally at 0-10% active when programs not responding, response time < 100ms
  • Resource Monitor -> no hint, though somehow some program always is accessing disk at ~10-100kB/s (which is not shown in Task Manager)
  • Process Monitor -> no expert on this, I did not see anything I could pinpoint
  • DebugView -> no expert here either, there were no messages though when programs were not responding
  • Disable Intel Rapid Storage -> this was one of my first suspects, this did not change anything though

Where to start the debugging, or do you already have an idea on where things might go wrong?

edit:
Problem continues. Still, only some programs are affected:

  • Notepad++ (and only when I have files open that are encrypted via Cloudfogger)
  • Skype for Business
  • Excel 2013 (perhaps also because there is a "bad" file in its recent file history)
  • Visual Studio 2015 sometimes takes 1 minute till the "new project" dialog becomes responsive

Also, I typically have a VMWare Windows Guest open, in that one I don't see any of the problems in response time.

  • 1
    Have you opened with Notepad++ some files that are on a network drive? Because sometimes I see something similar on my pc, and the reason is that when Notepad++ is minimized and I switch back to it, it tries to detect whether any files have changed, and if they are on a network drive which is slow to respond the program just freezes for some seconds. The fact you also see this with Lync makes me think it's network-related. In this case your upgrade of the SSD and RAM would be innocent. – Fabio says Reinstate Monica Aug 27 '15 at 13:43
  • No networked files but files in an encrypted folder (cloudfogger). I already disabled the "check open files for update" option in nopepad++, but still got the delay. (I always have same working files open.) I will try for a while with those files closed. – Andreas Reiff Aug 27 '15 at 15:26
  • Even though I like notepad++, I now tried it vs Sublime, which I also like but had not installed on that particular PC. With the same files open, it is a lot faster than notepad++ when going from minimized to normal. Perhaps I will give it a try, though it does cost money. I wonder if problem was there before and I just never cared because system is just a notebook (slow HD, SSD caching being completely unpredictable). – Andreas Reiff Aug 27 '15 at 19:32
  • 1
    One more idea about Notepad++: have you installed any plugins that are not part of the default installation? Is it possible they do anything? And are you using the latest version? Otherwise I have to give up, I have no more ideas, sorry. – Fabio says Reinstate Monica Aug 27 '15 at 20:08
  • I recently upgraded, and in the release notes it was talking about an unstable plugin, but then again, I have updated now. Also I added no plugins. Well, thanks you anyway, I will keep on looking. Perhaps someone also knows some tool on how to get better insight into what causes this. – Andreas Reiff Aug 28 '15 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.