I can see the printer, but I get “Permission denied.” I add everyone, guest, guests, set all privileges for all and always the same: “Permission denied.”

Not only home, but professional also can’t connect.

  • My guess is guests are disabled and Everyone does not include anonymous (since at least 7); so you need to correctly authenticate to use the printer; a way to do this is to have both computers in the same workgroup, to have a username on XPhome which is known to the Pro machine, and using the same password. Another distinct possibility is SMB signing requirements. – AntoineL Aug 28 '15 at 12:24
  • @AntoineL The same WORKGROUP - checked, user on xphome is passwordless, the same user on Win10 is also passwordless (user without admin). When I use Admin account with pass - credentials not enough sth. I don't understand SMB signing requirements... – Tomasz Brzezina Aug 31 '15 at 21:38
  • 1
    Fact is, this afternoon I got the same kind of problem from a XPhome machine (unrelated, debugging another issue) and I do use passwords. I will investigate further thus, and if I find something useful then I will post back here... – AntoineL Sep 2 '15 at 17:14
  • Just my two cents: First what did you mean in your original post where you said, “Not only home, but prof also can't connect.” What is “prof?” Does that mean “professional?” Or something else. Also, “Permission denied.” messages don’t always literally mean it is a permissions issue… It could simply be a protocol or driver mis-match issue as well. – JakeGould Sep 5 '15 at 18:50
  • @JakeGould - what else than professional could it be? – Tomasz Brzezina Sep 5 '15 at 19:34
up vote 3 down vote accepted

Finally I found the solution here; many thanks to wjacsh:

  1. You have to see the printer in explorer - so you have to log into \\Win10MachineName (with valid credentials)
  2. Add Printer - LOCAL Printer, new Local Port : \\Win10MachineName\sharedPrinter (e.g \\MyComp\HP1005)
  3. If the port is in use, find it in existing Local Ports
  4. Voila!!!

If you have problem with “Printer Processor not found or invalid” - change driver; don’t use the existing driver.

updated: There can be problems with credentials - if you are not logged in to \\Win10MachineName after reboot - the port is unavailable until you log in.

  • This one saved me the day. No way I would remember of adding a printer as Local, and then setting the location as a remote \\machinename\printer thing. Thank god windows is becoming more POSIX like. These hacks are frustrating for someone who uses daily several POSIX like systems – João Antunes Nov 28 '16 at 12:35

From XP:

Add Printer → LOCAL Printer, new Local Port

\\Win10MachineName\sharedPrinter (e.g \\MyComp\HP1005) or IP address Win10 (e.g. \\172.16.101.84\sharedprinter)

Check your Windows 10 advanced sharing properties. Enable file sharing for all networks and choose the option Enable File Sharing for Devices That Use 40- or 56-Bit Encryption (by default it's 128-bit). Then try printing again.

  • The OP has already marked this as complete. His issue was with incorrect credentials – Burgi May 31 '16 at 7:42
  • This one didn't work for me @SledgehammerPL's answer was the only way. I tried this first, and even disabling passwords, but to no effect – João Antunes Nov 28 '16 at 12:36

This helped me. I didn´t try badongero's solution (but looks good when having "only driver files" without setup)

My actual solution: First install printer locally. This involves running appropriate OS compatible printer drivers setup for USB connection (connecting for a while the printer).

Next make shure a connection to the server is open. Verify typing > NET USE in a CMD Window and if neccessary, just open in File explorer \\HostPC -write it in the direction box-, and credentials will be prompted.

Finally make the new local Port creation / assignment.

For badongero's way: First make shure an open connection to the HostPC exists. Then try the AddPrinter -> Local printer -> NewPrinterPort ...

Note: In some scenarios on rebooting PC, will not restore connection. Put a shortcut to File Explorer opening the Host machine in ..programs START folder to reset the connection everytime.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.