2

I have a peculiar problem with my home Wi-Fi router. The router is always seen by:

  • one MacBook Pro
  • MacBook Air
  • iPad
  • 2 Windows laptops

These devices can reliably connect to it and browse the Internet without any problem whatsoever; full signal strength.

However, from some point on;

  • 2 Android cell phones
  • TV
  • Kindle
  • printer
  • another Windows laptop
  • another MacBook Pro

stopped detecting the SSID. These devices used to connect to the network without any problems and I am not aware of any configuration change. All of these devices can detect all other networks around.

The following attempts were all tried with no avail:

  • changing a channel (all channels from 1 to 13 were given a shot)
  • changing security mode to none/WPA/WEP/WPA2
  • changing mode to 802.11g, 802.11b, mixed b/g
  • entering the SSID and password manually
  • hard reset of the router to factory settings
  • updating the firmware on the router
  • moving the router to a different spot

It always ended up with the same set of devices consistently seeing the SSID, the other set of devices never being able to detect it.

I am not as much interested in a practical solution (I can always just go and buy a new router) as in discovering the root cause - because frankly, it just doesn't make any sense.

3
  • You should edit your question to provide details as to the exact make/model of WiFi router you are using. Aug 27, 2015 at 19:01
  • 1
    Has the 2.4GHz radio failed, so only 5GHz is working? Can you check if the devices that can't see it support 5GHz wifi?
    – Mike Scott
    Aug 27, 2015 at 19:04
  • The router is 2.4GHz; all the other routers that do get detected are 2.4GHz, too... Aug 28, 2015 at 7:35

2 Answers 2

3

This usually comes down to either channel support issues (which you may have ruled out) or using a hidden (non-broadcast) SSID, which some clients had been configured to scan for (added to their preferred networks list) and others had not.

Make sure you haven't set your AP (Wi-Fi router) to hide its SSID.

As for channel issues, channels 12, 13, and 14 aren't available in all markets. If you have client devices that were designed for a different country than your AP was designed for, your client device might not be able to find your router if you set its channel to anything greater than 11.

Also, even if your equipment was all designed for, and bought in, the same country, some devices scan all the channels at boot, looking for APs in range that publish a country code IE (information element) in their beacons and probe responses, and then set their own country code and country-specific behavior to whatever country code they find in their scan. If a neighbor has an AP that publishes the wrong country code, some of your clients may be seeing that and setting their radios to that mode, where some channels are disabled. You can use a Wi-Fi scan tool that reports the country code of all discovered networks and see if you have any incorrect country code networks in range.

Overall, while troubleshooting this sort of thing, I'd definitely leave the channel set to 1, which is the most widely supported channel.

3
  • 1
    It goes without saying that SSID broadcast is on; that was the very first thing I've verified. I will try to look at country codes and report back. Aug 28, 2015 at 7:37
  • 1
    My router's country code is FI; the same as few other WiFi devices around that do get detected. Aug 28, 2015 at 15:02
  • 1
    If you're using Windows, then a good tool to find the country codes for neighbouring wifi is WifiInfoView.
    – Paul Jones
    Apr 11, 2019 at 9:54
1

I think that problem is do with the wireless bands. I would bet that all your problem devices only support the 2.4 GHz band and your router is now transmitting only in the 5 GHz band.

I had the same problem and the solution was to call my service provider. They did some black magic and the router started working properly again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .