22

I have been trying to open a new PuTTY window inside as one of ConEmu Tab, but no success so far, I've tried many combinations.

putty.exe -cur_console:b -ssh USER@DOMAIN 22 -pw PASSWORD
putty.exe -new_console -ssh USER@DOMAIN 22 -pw PASSWORD
ConEmu.exe /single /cmd putty.exe -cur_console:b -ssh USER@DOMAIN 22 -pw PASSWORD
ConEmuC.exe /ATTACH /ROOT putty.exe -cur_console:b -ssh USER@DOMAIN 22 -pw PASSWORD

what will happen is putty will be open in a new window outside ConEmu

1
24

I had the same issue, as I installed PUTTY by chocolatey.
In this case, if you call PUTTY, it will run the shim from the chocolatey\bin folder, and not the real exe.

As I put the whole path into the task, PUTTY appeared within the ConEmu window:

C:\ProgramData\chocolatey\lib\putty.portable\tools\PUTTY.EXE -load "saved session"
1
  • Similar issue here after using Scoop to install PuTTy. Similarly, I had to change the task to run from the scoop apps directory. i.e. C:\Users\<username>\scoop\apps\putty\current\PUTTY.EXE -load "saved session"
    – Rohaq
    Oct 16 '20 at 23:53
5

I had the same problem with putty launching a new window even when I was able to get notepad to work correctly and found your question in looking for a solution. I was later able to solve the problem as per below.

In the settings dialog for your command, under task parameters provide the following:

/dir <full path to your instance of putty>

Then in the Commands box provide something like this:

putty.exe -cur_console -ssh USER@DOMAIN 22 -pw PASSWORD

This should work. In my case I'm using something more along the lines of this:

putty.exe -cur_console -load <profile name>

If you want something you can just type in on the command line then something like this should work:

putty.exe -new_console:d"C:\Program Files (x86)\PuTTY\PuTTY" -ssh USER@DOMAIN 22 -pw PASSWORD
3
  • 1
    thanks, for some reason, it's still not working for me :( On the putty tab on conemu, it's showing this message: ConEmuC: Root process was alive less than 10 sec, ExitCode-0 Press Enter or Esc to close console.... It will open putty on a separate window outside of ConEmu
    – kjv.007
    Jan 21 '16 at 10:08
  • @kjv.007 updated with another option
    – Julian
    Jan 22 '16 at 15:01
  • @Julian Can you share a Figure about what you added in "settings dialog"? - I can see the current figure, but not sure what you added Oct 12 at 16:00
4

What worked for me is the full path inside quotes

"C:\Program Files (x86)\PuTTY\putty.exe" -load "your_session_Name"

Any thing else opened putty in a seperate window.

ConEmu version: 160724 32 bit. PuTTY Release 0.67 32 bit

4
  • This worked for me as well, granted I had already set up my profile
    – cbcoutinho
    Mar 26 '18 at 18:36
  • This is what fixed it for me. Putting the PuTTY path inside double quotes makes it work correctly. Sep 5 '18 at 11:10
  • This was the only thing that worked for me too.
    – iansedano
    Oct 12 at 7:12
  • Even when it works, it opens a new window. The point is do the connection within the ConEmu Oct 12 at 15:49
2

Just created a new ConEmu task with the following command:

PUTTY.EXE -cur_console -ssh <Login>@<HostAddress> -pw <Password>

works like a charm.

1
  • for me it's just showing these in my ConEmu Tab ConEmuC: Root process was alive less than 10 sec, ExitCode=0. Press Enter or Esc to close console... and then opening the usual putty window seperately.
    – kjv.007
    Aug 16 '16 at 8:54
1

The solution is, open the Task section, add a new task:

  • Give a name: for example PuTTY SSH 192.168.1.X
  • Leave empty the textfield (the second)
  • In the textarea (in the bottom) add one of the following commands according your preference:
C:\path-to-putty\putty.exe -ssh username@192.168.1.X
C:\path-to-putty\putty.exe -load "saved session name"

Do click at Save settings

Therefore, with ConEmu still running proceed to open a New console dialog... (or Win + Shift + W), it opens a new dialog window, in the first select box search the PuTTY SSH 192.168.1.X option and do click in the Start button and done!

Therefore with this approach you are able to:

  • Open in the same window many tabs to establish a connection for the same remote machine
  • Create many tasks as you need where each task represents a different connection to other remote machine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.