1

I'm attempting to install Xubuntu 15.04 x64 on a brand new high end laptop. I've already fixed a problem with the NVidia cards and needing to set nomodeset on boot but now I get this one kernel panic at all different run levels and at different times. It doesn't seem to have any apparent pattern or logic to it.

enter image description here

This happens during boot of the installation media and can happen almost instantly or shortly after fully booting into the desktop environment to start installation. Does anyone know what this is and how I can fix it?

Laptop specs and config (MSI GT80 Titan):

  • Intel i7 5th gen processor
  • 32 gigs system ram
  • 2x Nvidia GeForce 980M with 8 gigs each
  • Intel Wireless AC 7260
  • Mostly SSDs configured in RAID 0 (Stripe)
  • Secure Boot Enabled
  • Fast Boot Disabled
  • UEFI Enabled
  • Windows 10 installed (was installed with UEFI enabled)
  • Windows 10 Fast Startup is disabled
  • Windows Boot Manager has lowest priority on boot

I thought it might have been the wireless card but I tried removing the iwlwifi module and it still had a kernel panic. I've also tried using acpi=off, nolapic, and pci=noacpi but they don't help at all.

UPDATE

booting with nomodeset into runlevel 4, journalctl shows the following red lines:

ACPI probe failed
[/lib/systemd/system/casper.service:10] Failed to parse input specifier, ignoring: force-tty
iwlwifi 0000:05:00.0: Unsupported splx structure
conflicting device node '...' found, link to '...' will not be created
Device dev-disk-by\... appeard twice with different sysfs paths ...
name server cannot be used: Temporary failure in name resolution (-3)
DIS cannot start: GATT is disabled
Failed to init deviceinfo plugin
Failed to init proximity plugin
Failed to init time plugin
Failed to init alert plugin
Failed to init thermometer plugin
Failed to init gatt_example plugin
Unknown command complete for opcode 19
nm_device_get_device_type: assertion 'NM_IS_DEVICE (self)' failed
dbus: wpa_dbus_get_object_properties: failed to get object properties: (none) none
dbud: failed to construct signal

UPDATE 2

I'm not convinced that the errors you see in my screenshot are a problem. If I boot to runlevel 2, I can list all volumes in the raid sets with dmraid and I can even mount both /dev/mapper/isw_jibeadicf_Volume1p1 and /dev/dm-1 with no problems at all. Plus, it's an intermittent and sporadic problem appearing seemingly at random at different points during the boot process and at different points while in the desktop environment. If I can make it through a boot to any run level from 1 to 4 and get a terminal, it will not ever kernel panic, it will only kernel panic during boot or when in the desktop environment.

  • google.se/… - do you have RAID devices? – Hannu Aug 28 '15 at 8:07
  • bugs.launchpad.net/ubuntu/+source/linux/+bug/1358491 - comment #10 – Hannu Aug 28 '15 at 8:09
  • @Hannu Yes, I do. I'll take a look at your links right now. – vane Aug 28 '15 at 16:30
  • @Hannu comment #10 mentions editing /etc/fstab and that would be great if that works but this is installation media, not an installed instance of Xubuntu so how would I go about making that change. – vane Aug 28 '15 at 16:54
  • If you need to install on the RAID, then you will probably have to deal with it - I'm not sure how though :-I - I would have written an answer if I knew. Generally: You will probably need to get to a Terminal/bash prompt to access a relevant disk partition tool - so that you may set up your disks and create partitions. I'm not sure how to get there from the installation media, especially if it doesn't boot normally. – Hannu Aug 28 '15 at 19:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.