26

I recently saw an issue with Windows 10 with latest updates where language bar was missing for one particular account. I checked all the standard things and all check boxes/options which may be necessary for it to be displayed are in place (example of things I checked).

Could it be something to do with the fact that this is Microsoft account and no local/non-microsoft account/profile was created first? This new user has been added from the very beginning using Microsoft account.

Any ideas what can be done/checked here? Just try to recreate user profile or am I missing some better solution?

37

The problem can be solved by enabling "input indicator" Customize notification icons -> Turn system icons on or off

enter image description here

The quirk here is that once enabled you get the indicator but it may stuck at single language, i.e. switching does not work even though additional keyboard added. I solved it by adding and then removing extra keyboard layout:

enter image description here

|improve this answer|||||
  • @Mikhail I didn't added a keyboard layout, JUST switched it off and on, as I've mentioned in my original post. That's it =) – Alexey Vesnin Jan 14 '16 at 22:14
  • Thank You! I wondered where those settings had wondered off to... – Neonfirelights Aug 4 '17 at 21:51
  • OMG thank you; never do this when implementing an interface! the option was nowhere to be found in any search/control panel option related to Language! – Chaim Eliyah Apr 6 '18 at 19:06
  • I switched it on, off, on again, and the indicator doesn't show up. What to do? – AgentFire Sep 20 '18 at 18:03
  • Try language settings in Control Panel - after an update you may need to toggle it there also – Alexey Vesnin Sep 21 '18 at 14:44
2

User has to be member of the "Administrators", to access Control Panels!

Provided the above is met, to open the "Language" Control Panel: In Explorer (or Run menu, [WinFlag+R]) paste this path

Control Panel\All Control Panel Items\Language

There is a button above the language list "Add Language". Click it to add one. As soon as you have more than one language listed, in System tray appears the indicator, from which they could be changed.

|improve this answer|||||
  • @Yes there is an extra language added for this user so it seems to be something else... – Mikhail Aug 31 '15 at 7:52
  • 1
    Go in Control Panel Control Panel\Clock, Language, and Region\Language\Advanced settings In the middle put e tick on "Let me set a different language for each app" And a tick below on "Use Desktop Language Bar, when it is available" Then click to the right on "Advanced Settings" or "Options" and set the Bar to appear as "Docked in the Taskbar" – Victor Ivanov Sep 11 '15 at 21:20
0

I think we can close this question as I solved this. This was some issue with expired Windows Insider build which was unable to receive any new updates. I tried to add new Microsoft Account and get the same issue, then checked build (it was expired) - I installed RTM build and language bar working OK now. So I think this was an issue specific to this early build.

|improve this answer|||||
  • 1
    You can “close” questions by accepting an answer. It can be your own answer. However, please make it a proper answer, as if you were answering somebody else. – Daniel B Jan 14 '16 at 16:16

Not the answer you're looking for?Browse other questions tagged or ask your own question.