1

I am actually wondering how to prevent services (in this case the X server) in Ubuntu (14.04) from startup automatically at boot time. I tried:

sudo update-rc.d lightdm remove

and

sudo update-rc.d lightdm stop 2 3 4 5

but the session managager starts up nevertheless. What piece of Ubuntus startup system I have to work with in order to do the job?

Thanks for your help!

0

As far as I know, this is configured within a parameter in the GRUB default file.

Edit your /etc/default/grub file and there should be a parameter called GRUB_CMDLINE_LINUX_DEFAULT. Change its value to text.

After that, don't forget to update your GRUB config:

sudo update-grub2

  • Ugh - That worked out for me. Thanks! I now could start X manually by issuing "sudo service lightdm start". But I really think the Ubuntus startup/service system is quite a bit too decentralized... I would never have come to the idea that this could be configured within the GRUB configurations :( – fragwürdig Aug 28 '15 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.