I am using the latest test build of Virtual Box (normal versions don't work on El Capitan).

When trying to boot a Virtual Machine with an El Capitan cdr file (created from the command line) I end up getting the UEFI shell instead of the OS X installer.

enter image description here

How would I be able to boot the El Capitan cdr file? I am also running El Capitan as the host too.


4 Answers 4

  1. Type exit at the UEFI Shell Prompt
  2. Go to Boot Maintenance Manager
  3. Choose Boot From File
  4. Go to Preboot....
  5. Navigate through [Some GUID] -> System -> Library -> CoreServices
  6. Finally select boot.efi

Your machine should now boot up. Works for me for Big Sur.

  • Note after step 6 you have to wait a lot and see lots of scrolling text before system starts to boot.
    – Marek R
    Dec 12, 2022 at 15:51

You have to disable EFI boot in the machine settings. Then it will work, however, you will have to have Chameleon installed on the .cdr image.

  • 4
    Why the downvote? At least say what's wrong with my answer...
    – redbeam_
    Nov 5, 2017 at 23:26
  • 2
    For some toxic reason, the SE community sometimes downvote answers automatically if your rep looks too low. yep, hen-and-egg
    – Pacerier
    Mar 19, 2018 at 15:42
  • This solved this problem for me.
    – John Smith
    Feb 22, 2019 at 4:05

This is not working in VirtualBox at the time of writing (2015-10-07).

Apple migrated the format of the partition table for El Capitan boot image from MBR to GPT and VirtualBox does not yet support HFS+ filesystems on GPT partitioned drives when starting from EFI.

Refer to this issue:



The easiest way to not get this error is to use VMware Workstation Pro.

Even if you prefer VirtualBox, if you even more prefer to do things the easy way, install VMware Workstation Pro.

You can install it here.

I have not tried this method myself, so I cannot guarantee that it will work.

Thanks for taking your time to listen,


  • If you haven't tried it and aren't sure it works, how can you say it's the easiest solution?
    – fixer1234
    Apr 13, 2018 at 19:12
  • Because I have tried it on an older version of VMware.
    – Zyrom121
    Apr 18, 2018 at 18:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .