2

I have went on to Google search before, however today, Mozilla Firefox won't let me connect to Google's search page.

This is what I get.

You have asked Firefox to connect securely to www.google.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

www.google.com uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported.

(Error code: sec_error_unknown_issuer)

I tried uninstalling and resetting Firefox but I still get the same message. (Also Internet Explorer opens the page just fine.)

UPDATE: Only one user out of the three on the computer doesn't have this problem.

  • 1
    This is because Firefox and IE use entirely separate certificate stores. Based on the error your system is configured to use an invalid certificate when it connects to Google. You should export that certificate into the Firefox certificate store. – Ramhound Aug 28 '15 at 14:13
  • 1
    How do I do that? – John Aug 28 '15 at 16:47
  • How you add a certificate to the Firefox Certificate store specifically depends on the version of Firefox you are using and the operating system you are using. In all cases how you do it is documented on in a Firefox support article. – Ramhound Aug 28 '15 at 17:01
2

Firefox is protecting you from what it thinks is a man-in-the-middle attack, where some other program is intercepting and possibly altering your communications with Google. It's possible that your connection is actually being hacked, but another common possibility is that you (or your employer) has a firewall which inspects and possibly alters your web traffic for legitimate reasons. In that case, you would need to tell Firefox to allow that interception, by installing the firewall's certificate in Firefox's trust list.

You have a couple of options:

  • Ask your system administrator or IT department, if you have one. They will be able to confirm that this should be happening, give you a copy of the certificate, and perhaps help you install it into Firefox (usually under Preferences > Advanced > Certificates but it varies by version).
  • View the Google certificate in the error dialog that Firefox shows. It will have a "Subject" (which should be Google) and an "Issuer" (which, for the real Google, is GeoTrust via an intermediate Google certificate, but for a firewall will probably be named after the firewall vendor). If you recognize this issuer as legitimate, you can find the certificate in Windows' trust list, export it, and then import it into Firefox's list of trusted certificate authorities.

Firefox, for historical reasons, has its own trust list separate from Windows', but IE uses the Windows list. It sounds like the intercepting certificate is in Windows' trust list and in one user's Firefox list but not in other users' lists.

  • I copied a Firefox profile from a working computer to a new computer, and the certificates seem to be included in the profile, but the new computer's firefox isn't working, Anything else I need to do to make it work? – endolith Sep 27 '16 at 19:25
1

I had this problem after downloading a subtitles file (.srt) from internet. It must have included a malware to change my setting in Firefox. I had to uninstall the firefox and delete all my settings from profile. Please see:

https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer

After removing all setting and reinstalling firefox the problem was solved.

1

I had the same issue.

You can enable some feature in about:config by creating this boolean value:

security.enterprise_roots.enabled

and set it to true

For more information follow this.

0

I had the same issue. I am behind a Enterprise firewall. As Wim Lewis mentioned in his post, I added the Certificates from the FW to the "Options" -> "Advanced" -> "Certificates" -> "View Certificates" -> "Your Certificates" -> "Import"

Once the certificate(s) were imported, it started working.

-2

Firefox a Web browser that is smaller and faster which enables users a cleaner interface and faster download but there might exists a problem like Mozilla firefox can't connect server so to fix it user must check computer's network connection, if using a proxy server make sure that it can connect to the internet, as well as check the address for typing errors such as ww.example.com instead of www.example.com.

  • Welcome to Super User. This is really just a few generic comments relating to browsers and Firefox. There's not anything here that's a solution to the problem in the question, or specific to the issue in a useful way. With a little more rep, you would be able to post a comment with helpful hints. Answers are intended to be solutions. – fixer1234 Jun 29 at 19:22
-3

Firefox Won't Load Webpages, But Other Browsers Do

Try following the steps on this Firefox help page. I think this might help. Also, as a sidenote, is your system time correct? The following info is from the Mozilla Article linked.

Internet Security software blocking Firefox

If you were able to load websites until you updated Firefox or until your Internet security software was updated, reconfigured or a new one was added, your Internet security software (including firewalls, antivirus programs, anti-spyware programs, and more) is likely preventing Firefox from connecting to the Internet.

Note: Some Internet security programs can block Internet access even when they are in a "disabled" state. In general, you should make sure your Internet security software is up-to-date and remove Firefox from your program's list of trusted or recognized programs, then add it back. For instructions on how to configure some programs, see the Configure firewalls so that Firefox can access the Internet article.

Firefox connection settings

If you connect to the Internet through a proxy server that is having connection problems, you will not be able to load websites. To check your Firefox proxy settings:

Click the menu button New Fx Menu and choose Options. Select the Advanced panel. Select the Network tab. In the Connection section, click Settings…. Change your proxy settings: If you don't connect to the Internet through a proxy (or don't know whether you connect through a proxy), select No Proxy. If you connect to the Internet through a proxy, compare Firefox's settings to another browser's (such as Internet Explorer — see Microsoft's guide to proxy settings). Close the Connection Settings window. Close the about:preferences page. Any changes you've made will automatically be saved. If you find that changes you make to your Firefox connection settings are not remembered when you restart Firefox, see How to fix preferences that won't save.

IPv6

Firefox supports IPv6 by default, which may cause connection problems on certain systems. To disable IPv6 in Firefox:

In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page. In the Search field, type network.dns.disableIPv6. In the list of preferences, double-click network.dns.disableIPv6 to set its value to true. DNS Prefetching

Firefox attempts to speed up loading new websites by using DNS Prefetching, which can cause page load errors with some system configurations. To disable DNS Prefetching:

In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page. Right-click in the list of preferences, select New, and then select Boolean. In the Enter the preference name window, enter network.dns.disablePrefetch and click OK. Select true when prompted to set the value and click OK. Firefox cannot load certain websites

If you find that Firefox can load some websites but not others, first clear your Firefox cookies and cache:

Click the menu button New Fx Menu , choose History and select Clear Recent History.... In the Time Range to clear: drop-down, select Everything. Click the arrow next to Details to display the list of items that can be cleared. Select both Cookies and Cache. Click Clear Now. Check for malware If clearing your cookies and cache did not enable you to load the websites that did not work in Firefox, you should check your computer for malware. Certain types of malware are known to target Firefox and can prevent it from loading various websites:

If you have an antivirus or Internet security program, update its detections database and do a full scan of your system. If you still have problems, follow the instructions in Troubleshoot Firefox issues caused by malware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.