2

I have a CoolerMaster XCraft 360 with a 8TB drive in it. It's formatted using the NTFS file system. It's almost 25% full, so I'm just about to hit the magic 2TB mark. When I'm trying to copy a file to the drive, Windows 10 gives an error: Error 0x80070057: The parameter is incorrect.

I've found several references to that error code, but none seem to apply to my situation (either Windows Update or Windows 7-specific). I tried changing the number format setting as described, but that didn't solve the problem.

I'm guessing it has something to do with adressing past the 2TB mark, but I'm not sure how to get Windows to fix that problem.

  • How did you connect the enclosure? Via the eSATA port of did you fall back to the USB port? Asking because I see no reason why windows 10 would not handle that natively, but when an USB to SATA bridge is in the loop all bets are off. – Hennes Aug 29 '15 at 11:31
  • My new motherboard doesn't have an eSATA port, so it's connected to a USB 3.0 port. – Jorn Aug 29 '15 at 11:49
3

I was in the exact same situation as OP, large (2TB+) hard drive in a USB dock, hitting the wall at 2 terabytes of data and getting the ambiguous error 0x80070057. The problem was that the dock didn't support writing past the first 2 terabytes of a large partition. The solution is to use a different dock with the appropriate chipset.

I'm not very knowledgeable about which chipsets are appropriate, but luckily I had a Plugable brand dock already which worked for my 3TB drive. Plugable heavily advertises their products' compatibility with large drives when available. Do your research before buying one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.