1

I have created an account to share files on a Windows 7 computer (C:\Users\share), and have mounted this directory as drive N:\ on other Windows XP computers (3), and the 7 computer (for convenience).

For simplicity, I will call:

  • the Windows 7 computer (a Samsung Sens R410) "7",
  • the 1st Windows XP (Samsung Sens N145 Plus) "XP1",
  • the 2nd Windows XP (Fujitsu C1320) "XP2",
  • and the 3rd (Dell Vostro 1310) "XP3".

XP1, 2, and 3 can see 7 and each other, and therefore can use N:\ without problems, and can access each others' files.

The problem comes when 7 tries to access XP 1, 2, or 3.

In Network, when 7 clicks on XP1, 2, or 3, it cannot access it.

My primary goal was to make the connection available XP -> 7 and vice versa, because XP1 has all printers connected to it, and theoretically, print remotely.

Is there any fix?

Note 1: I am not sure if I have turned on printer sharing on XP1.

Note 2: The printers are:

  • HP Photosmart C4280 All-in-one,
  • and a Brother HL2130.

I am DEFINITELY sure that I have the HP printer installation disk, and not sure if I have the Brother printer disk.

Note 3: All computers are on the same workgroup, but the name is not in English (just wrote this if this could have an effect.)

2
  • File and printer sharing must be enabled on all pc's. – Moab Aug 29 '15 at 17:59
  • Only XP1 has a printer, the others don't. And on the XPs, they can access the files on each other, meaning that it is probably enabled. On 7, I have enabled it. – Yubin Lee Aug 29 '15 at 18:01
1

To fix this, I went to Control Panel -> Windows firewall. Then UNCHECK "Do not allow exceptions" or something of the like (my xp is not in english). Then it will work just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.