9

My computer has been waking out of sleep since I've upgraded to windows 10. It usually sleeps for many hours before waking. This is a desktop PC.

C:\WINDOWS\system32>powercfg lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

C:\WINDOWS\system32>powercfg -devicequery wake_armed
NONE

I have "Allow sleep timers" disabled under the advanced power settings.

Automatic maintenance "Allow scheduled maintenance to wake my computer at the scheduled time" is unchecked.

"Wake the computer to run this task" under "Task Scheduler" is unchecked for all tasks.

I do not have TeamViewer installed which was this guy's problem

Does anyone have any idea what could be waking my PC up or what I could do to identify it? Or if there is any way to force the PC to sleep no matter what until I hit the power button?

11
  • A few possibilities: wake-on-LAN, if there is another device on the system; Windows Update, which, until a recent patch, could not be prevented; vibration causing the mouse to move (though that is not Windows 10-specific). – DrMoishe Pippik Aug 30 '15 at 4:30
  • Check Event Logs to see if the reason is mentioned – Sami Kuhmonen Aug 30 '15 at 5:12
  • 1
    @SamiKuhmonen powercfg get its information from the event logs - the event will say exactly the same. – DavidPostill Aug 30 '15 at 7:17
  • @DrMoishePippik, none of my network devices have "Allow this device to wake the computer" checked. As seen above, none of my devices are wake_armed (including mouse and keyboard). I meticulously went into all of my device power management properties to make sure none of them were able to wake my computer. I see there is an update available... I'll try that and see if it stays sleeping. Seems like it has been waking up 12-20 hours after sleeping it, so it will take awhile to report anything. – Dallas Aug 30 '15 at 14:12
  • 1
    Possible duplicate of superuser.com/questions/464578/… – sancho.s ReinstateMonicaCellio Jul 13 '16 at 5:56
2

The "Wake on Magic Packet" option may turn the computer on (if someone/something is pinging the computer). Go through Device Manager to resolve this and not the Network and Sharing Center (see EXPLANATION below).

STEPS:

  1. Open the "Device Manager"
  2. Open the "Network adapters" tree
  3. Select your adapter (you may have two if you have both wireless and Ethernet capabilities)
  4. Right-click on the adapter
  5. Select "Properties"
  6. Select the "Advanced" tab
  7. Under the "Property" box, scroll down and select "Wake on Magic Packet"
  8. Change the "Value" drop-down box to "Disabled"

EXPLANATION: You can go through the "Network and Sharing Center" by selecting "Change adapter settings" on the left side of the screen; selecting your adapter's "Properties"; selecting "Configure"; and then going to the "Power Management" tab. However, I've noticed on some of my computers (including Windows 7), that the magic packet option will be grayed out or unchecked in the "Power Management" tab but be "Enabled" in the "Advanced" tab.

Using the Device Manager route solved my issue with unwanted waking from sleep on my laptop. Good luck.

0

I had the same problem. All configurations correct, yet the PC kept waking even though wake timers was disabled, and update wasn't allowed to wake the PC as well. After days I figured out that Spotify has recently (past month) changed, and adds waketimers!

On windows 10, the "allow waketimers->disabled" option in the power settings is ignored (at least, it does not what it should do: prevent waketimers to wake the PC from sleep!). Thus, the waketimer set by Spotify AFTER opening spotify, was actually causing my PC to wake from sleep.

If you have the latest version of Spotify, it might be the cause of your problem as well. You can remove the spotify waketimer via this code (Source)

taskkill /IM Spotify.exe /T /F
taskkill /IM SpotifyCrashService.exe /T /F
taskkill /IM SpotifyWebHelper.exe /T /F

Put the code in a BAT script and run it prior to turning your PC to sleep. You might as well add this code (Source)

rundll32.exe powrprof.dll,SetSuspendState 0,1,0

to turn your PC to sleep from the same bat file (saves a little time)

1
  • 1
    I don't have spotify. I backed up all my files and reformatted (or "reset") windows 10 without keeping any apps or anything and I think its staying asleep now... but perhaps this might help someone else. I really think there should be an option to say "sleep and don't wake up for anything else except me hitting the power button" =\ – Dallas Sep 28 '15 at 2:58
0

Are you sure it's on sleep mode and not crashing? Windows 10 + nVidia = TDR still... they haven't solved this issue yet (at least for the systems that only have a dedicated GPU)
First step, uninstall P4G, restart, change all the power values to your choice, make sure that you select the correct power option, restart, test.
BTW, on windows 10 there are 2 areas for these options. One is the typical power configuration which we all know about, and the other one is in their "settings" option from the start menu. Check both.

0

My PC started doing this after the latest Windows 10 update; instantly go to sleep after 15 minutes of no usage, as intended, but then 5 or 10 minutes later it booted up again and that cycle goes on all day. Hope this batch file helps you.

powersleep.bat :

@echo off
&mode 32,2 &color cf &title Power Sleep
set "s1=$m='[DllImport ("Powrprof.dll", SetLastError = true)]"
set "s2=static extern bool SetSuspendState(bool hibernate, bool forceCritical, bool disableWakeEvent);"
set "s3=public static void PowerSleep(){ SetSuspendState(false, false, false); }';"
set "s4=add-type -name Import -member $m -namespace Dll; [Dll.Import]::PowerSleep();"
set "ps_powersleep=%s1%%s2%%s3%%s4%" 
call powershell.exe -NoProfile -NonInteractive -NoLogo -ExecutionPolicy Bypass -Command "%ps_powersleep:"=\"%"
exit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.