4

If font rendering is handled by the OS for both my web browser (firefox / waterfox), and my text editor (notepad++), why do they look so much worse in the text editor? I see the same subpixel rendering in both, but the anti-aliasing seems to otherwise be worse in the editor. This has been really bothering me for a long time. See image for comparison, internet browser is on the right

http://i.imgur.com/VEzuuQK.png

This shot isn't zoomed in

edit for comment: I don't know about DPI, it's just a screenshot. OS is Windows 7. Neither side is scaled differently than the other, it's a single, cropped lossless screenshot, not two separate screenshots. (edit: NOW it's two screenshots, one on top and one underneath it.) They're both being directly rendered. With font size 10 and no zooming at all, default scale, the exact same artifacts are still there on the text editor side. Actually, that makes them far more pronounced than they are in the screenshot. I zoomed both in for the shot, intending for it to be opened and viewed at native resolution, so you could see the details more clearly. That's also why I didn't embed the image in the post, someone else did.

Anyway, I added a second shot below the first that isn't zoomed in. The same artifacts are present in both, but the two different zoom levels help demonstrate their nature. I strongly encourage anyone reading this to click them and open the files, so that they can be viewed natively. Looking at the embedded, rescaled thumbnails reveals nothing. The first shot, helps more than the second. Look at the bottom of the capital G, and the top of the lowercase l. One has antialiasing where the other seems to have practically none by comparison, other than subpixel. I do a lot of text and code editing and reading, and this has been a thing for a very long time, so it is an issue that I've always needed to fix.

edit: I just installed MacType as suggested by a commenter, and as given by their link, and thank you, it has indirectly fixed by problem. I still don't know why it rendered differently in the first place, but now that MacType overrides all rendering, it's good now. Though, the browser rendering is still better than notepad++, that of notepad++ is at least significantly improved.

2
  • what is the DPI set for? what is the OS? it looks to me like one is properly sized font, drawn at the vector level, the other looks like the font (or page) is scaled after being vector sized. They both look fine compared to other problems people have seen. – Psycogeek Aug 30 '15 at 10:37
  • If you're on Windows, consider installing MacType. It makes font rendering way better for almost every application you have installed. The installer for MacType may not be easy to come by right now as the primary distribution website is down but you can get a copy here – Vinayak Aug 30 '15 at 14:44
0

In Editing tab of Preferences window, check Enable smooth font.
This option was not present before.

0

In older versions of GDI, ClearType does not have symmetric smoothing (vertical anti-aliasing).

Have you tried disabling ClearType?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.