3

I am running vmware workstation 11 on windows 10, and it seems Unity mode doesn't work.

I've tried both Debian (jessie and stretch) with gnome-fallback (metacity), kde, and xfce as well as Ubuntu 15.04 with xfce & gnome-fallback (metacity) as guests. Every time I tried to enter Unity i get the message

The virtual machine cannot enter Unity mode. Check that Unity is supported for this guest operating system and that the latest version of VMware Tools is installed.

I have open-vm-tools and open-vm-tools-desktop installed on all of them. I also ran the vmware-tools installer after to install all it's kernel modules and whatever else it does.

4
  • By Unity mode do you mean the VMWare feature or do you mean the desktop environment? If you mean the desktop environment, it seems there are a lot of issues with it and it's unlikely to work (see: askubuntu.com/questions/227712/…) – XtrmJosh Sep 1 '15 at 19:25
  • I mean the vmware feature. – Epicblood Sep 1 '15 at 19:26
  • 1
    I'm not so clued up on the feature itself, but have you tried running vmware-config-tools.pl? There are a lot of people out there saying this worked for them - should be in the guest tools disc image. – XtrmJosh Sep 1 '15 at 19:29
  • That seems to have fixed it, idk how I didn't find that on my own. Go ahead and answer the question and I'll mark as accepted. – Epicblood Sep 1 '15 at 19:58
3
+50

Running vmware-config-tools.pl should fix this - the issue may return on reboot, in which case you could automate the running of this script at startup, or find a way to better integrate the changes it makes.

3
  • thanks, just rebooted it a few times to make sure, but seems like the issue isn't returning. I'll award you the bounty as soon as I can :) – Epicblood Sep 1 '15 at 20:10
  • so this works just fine as long as I don't have any extra monitors plugged in, I made a post here. – Epicblood Sep 3 '15 at 1:56
  • 1
    Ahh damn. I'll respond on Reddit since it's more in my scope :) – XtrmJosh Sep 3 '15 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.