I recently noticed that one of my external hard drive seems to be missing a lot of space. It was recommended that I try WinDirStat, as it could help identify how much space each file was taking up. This is the result:


As you can see, there is about 244.7GB "unknown" usage.

Doing a bit of research online, the most common suggestion was (a) Recycle Bin and (b) System Volume Information.

(a) As you can see, empty. To double check, I ran Disk Cleanup. It confirmed that it was empty. (Note that a new file appeared by the time I took this screenshot, but it's only 129 Bytes.)

(b) Harder to tell. However, according to various forums, the most common reason for System Volume Information to grow large is due to System Restore Files. I had a look, and it is definitely turned off for this drive, as seen here:


What else could be causing this issue? It is an enormous amount of storage to have gone missing!

  • "System Restore Files. I had a look, and it is definitely turned off for this drive" - was it ever turned on in the past? – DavidPostill Aug 30 '15 at 10:23
  • 3
    Did your run windirstat as administrator? – DavidPostill Aug 30 '15 at 10:28
  • @DavidPostill This is the first time I've checked system protection settings since buying the drive earlier this year, so I'd say that it has never been turned on. And yes, this was run as administrator. – BSnapZ Aug 30 '15 at 10:53
  • Did you upgrade to Windows 10 from a previous version of Windows? Perhaps there were files on the drive from the old version that now have the wrong owner/permissions and cannot be read by WinDirStat. – DavidPostill Aug 30 '15 at 10:55
  • 2
    I prefer TreeSizeFree over WinDirStat . Run TreeSizeFree as admin to see more. – magicandre1981 Aug 30 '15 at 18:22

Instead of windirstat you should use TreeSizeFree.

enter image description here

Run it as admin, so that TreeSizeFree shows all hidden/system files.

  • 1
    Thanks. In my case, it showed that the <unknown> space of 40 GB was the virtual drive used for Docker (C:\Users\Public\Documents\Hyper-V\Virtual hard disks\MobyLinuxVM.vhdx). – Michaël Polla Nov 5 '17 at 14:54
  • I also have the MobyLinuxVM.vhdx which is about 2gb. And I have a similar situation, but how can I confirm that it's docker related? superuser.com/questions/1371209/sd-card-has-26gb-large-file where did you find that? Since both windirstat and treesize do not show a name or anything even when I run it as admin. – JP Hellemons Oct 31 '18 at 10:30
  • 1
    I don't see how TreeSize can help. I have an <unknown> of 100.6 GB on the C-drive (reported by WinDirStat) and TreeSizeFree reports a Size of 54.2 GB and 54.3 GB Allocated on C-drive. The total size of the C-drive is 213 GB. – AH. Oct 21 '19 at 9:05
  • 1
    you need to run it as admin... – magicandre1981 Oct 21 '19 at 14:40
  • I tried TreeSize and it cannot free "unknown" space for instance allocated by multiple restore points. – AH. Oct 31 '19 at 8:58

Running Windirstat as Administrator will reveal most of this. In some cases it can be system protection files, corrupt files, old installers, or in my case, the Recycle Bin.

Per the Windirstat Propaganda Blog,


This mysterious item is just the difference between what Windows reports as the free space on the volume minus size of the files WDS can access. Please note the part WDS can access! This is the important point here. WDS cannot access the files under System Volume Information on all the (NTFS?) drives, so it cannot sum up the sizes of these items. And by the way, we have had reports of up to 30 GB of “” space.

The root of the problem is permissions, apparently.

  • 1
    Thanks, run as administrator brought my WinDirStat <Unknown> space from gigabytes to zero. – Bob Stein Jul 29 '20 at 12:54
  • Yep, no need for different software, just run as admin. Turned out to be a game installed via the Xbox app in my case. – Matt Lacey Apr 27 at 23:13

In my case it's the Windows search file, Windows.edb, in: \ProgramData\Microsoft\Search\Data\Applications\Windows.

  • Can you please elaborate a bit more for what the file is and how much it takes up for other future answer seekers? – Eric F Apr 9 '19 at 19:12

This might be of interest, or not. I run WDS (NOT as admin) and get 7.3GB unknown. Program files 1.7GB. When I run it as admin I get 5.2 and 3.2GB respectively. There are other differences too but I won't muddy the water by posting all of them. It's definately a permissions issue for me. For example the difference in Program files is the WidowsApps directory. I changed the owner from Unable to display... to ....\users and WDS sees it in either mode (no admin/admin). Same for SystemVolumeInformation, despite not being able to change owner for all items. Found all but 0.6GB of unknown space. Some of the remainder is in ProgramData and small amounts in other places e.g. Config.Msi. I am not so concerned as to spend time hunting through the whole drive and changing premissions but I now understand the differences. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.