I recently upgraded Windows 7 to Windows 10. The biggest issue I have now is that the Windows Search service no longer works, making the Start menu mostly unusable.

If I go to Indexing Options in the control panel I see that Indexing is not running and the list of paths to index is empty.

Going to advanced options, the current index path is empty, and the new path is empty too. This is true even if I try to use the "New Index" button.

Using the troubleshooter won't help since the service doesn't start. If I try to manually start the "Windows Search" service, I get the error "Error 3: Unable to find specified path" (this is the rough translation, the original message is in my language).

What can I do to find out which path/file is missing ? I tried to check with Process Monitor, but the only file (beside system libraries) the SearchIndexer.exe try to access seem to be c:\ProgramData\Microsoft\Search\Data\Application (everytime the service is started the whole folder c:\ProgramData\Microsoft\Search is deleted and recreated) and C:\Windows\System32\config\systemprofile (which exists).

Edit: all available updates are installed, and issuing

SFC /scannow

Doesn't reveal any issue

  • have you done the updates yet? only because there were many changes to this whole set already in 2+ cumulatives. Also doing a SFC /scannow would probably be better at first than tracking down all the parts and peices that are needed to work correct. – Psycogeek Aug 30 '15 at 14:42
  • Yes the system is up to date. I firgot to mention that I already tried with SFC /scannow but no issues where found. I will update the questione accordingly – Marco Righele Aug 30 '15 at 14:55
up vote 3 down vote accepted

The problem is due to the fact that before the upgrade the search index was on a different drive. One that was no longer available after the upgrade.

As soon that I changed the value of HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager\DefaultApplicationsPath to a path on the drive C: the Indexer started working perfectly. (There were other paths to fix, but the above is the one that would cause the service to fail).

Strangely enough, the path involved and the missing drive were not among the path returned by Process Monitor.

After much research I finally was able to restore indexing in my Windows 10. The message I received was about error 3 mentioning that the system was not able to find the specified path.

Tried several "recipes" with no success and was almost performing a refresh install, then I found your comment about the index pointing to a non-existent drive. In my case, these keys were pointing to a "G:" drive:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager G:\Windows_Index\Search\Data\Applications\ HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\TempPath G:\Windows_Index\Search\Data\Temp\usgthrsvc

First I used services.msc to disable the Windows Search Service.

Windows 10 Registry Editor does not allow editing of these keys. I downloaded and installed the free home edition of "Registrar Registry Manager" from

http://www.resplendence.com/main and was able to change the keys to the following values:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager\DefaultApplicationsPath to value: C:\Windows_Index\Search\Data\Applications\

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager\TempPath to value: C:\Windows_Index\Search\Data\Temp\usgthrsvc

Under services.msc I made the change for windows Search to start automatically (delayed start). It started normally as it should.

Quick Fix : Similar issue...

Installed an SSD as main drive and had search using my E drive as its index file location (less wear on the SSD). I later swapped my E drive and replaced with a 4TB storage drive which was mapped to a different drive letter.

Indexing broke with Error 3 path not found.

Changed the drive letters in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager\DefaultApplicationsPath and ...\TempPath back from E:\... to C:\... drive. You will need to change the Gathering Manager keys Permissions Owner from TrustedINstaller to Administrators for permission to change the drive paths.

I was able then to restart indexing service. Everything immediately started working.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.