I am looking for a tool to measure one way delay. I have found a tool One-Way Ping (OWAMP). But I am unable to install on my machine.

I am using Mac OS X. I have been searching on Google but having found any other tools for Mac on installation process for Mac.

Does any one have been in such situation?

I have got these in end when I run ./configure file

checking for library containing I2AddrByNode... no
configure: error: Couldn't find I2util library

and when I run make, I get this error

make: *** No targets specified and no makefile found.  Stop.

and when I run make install I get this error make install make: Nothing to be done for `install'.

2 Answers 2


You list the output of three commands without seeming to understand them.

Configure complains that it cannot find the I2util library. It fails.

You try to ignore that and compile anyway. This fails since the makefile is not yet ready, probably because it requires you to run the autotools first (which failed in the previous step). Result: nothing is done.

Next you try to find the tool (which was NOT build in the previous step) and try to install it.

Lets repeat this in non-computer terms. Car-analogy:

  1. You try to unlock a car but fail.
  2. Then you are told to press a button in the car to open the fual tank. Since it is locked you cannot reach it.
  3. Next you report an error while putting fuel into the tank...

Obviously you need to go back to step 1.

Why did configure fails to find the I2util library?
Is it installed on your system and do you need to help configure find it? Is there anything about it in the README file (hint: yes, there is. And the directly with an install script for I2util is also present)

finally, from the INSTALL file:

$Id: INSTALL,v 1.2 2003/03/20 02:28:59 boote Exp $

Currently owamp has only been tested on FreeBSD - specifically versions 4.6 and 4.7

That is not the same as Mac OS X. And FreeBSD 4.x was from about 2002.

Knowing that, you cannot realistically expect a simple ./configure && make install to work. You will have to modify the program with some understanding of how it works and what the differences are between current day Mac OS X and 2002 era FreeBSD.

After your edits to your post and some more testing:

I do not have access to OS X so I installed a FreeBSD VM and tested.

  • Fresh clean install of a recent FreeBSD (10.2)
  • Populate the ports: (portsnap fetch && portsnap extract)
  • cd /usr/ports/*/owamp && make install -DBATCH).

The ports three fetched data from the same place as your time patch and compiled without a hitch. It is installed an older version though (v3.3).

Next: trying the tarballs:

  • get the latest tarball: lynx http://software.internet2.edu/sources/owamp/, selected owamp-3.4-10.tar.gz 07-Nov-2014 20:46 642K
  • extracted the contents (tar xzf), ran ./configure

And blam. Same error as you got. Cann't find I2util.

My first reaction was to add a library path to I2util, but when I ran ./configure -h I noticed this:

Output from ./configure -h incl I2util path

I googled a bit and ran into this tread. On a not so subtle hunch I copied the I2util folder from the ports version to the latest version and ran configure. This time it ran without a hitch.

While not exactly subtle and and not tested on OSX, you might want to try an older version which still has I2Util, or you mioght want to install I2util from a different package and supply the path, or you might do the ugly trick and use the latest tarball and add part of an earlier tarball.

And should you find a way to to this with brew, please post it as an answer. (no OS X also mean no testing with homebrew).


It seems like at one point you could install owamp via Homebrew. Clued in by the instructions on this page. But not anymore? See “Realistic Caveat” at the bottom of this answer for some detective work I did.

Optimistic Homebrew Install Details

Now if this Homebrew recipe were still available, you would first need to install Homebrew as per the official instructions by running this command from the terminal like this:

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

And then when Homebrew is installed just run this brew command to install owamp on your system:

brew install owamp

Realistic Caveat

Now, all of that said it seems like owamp is no longer a part of the Hombrew menu of Mac OS X install recipes? I found this commit titled “owamp: migrating to boneyard” which shows the Hombrew insall recipe being removed from repository. And then that refers to this issue ticket which asserts that the core patch once located here—and required for Mac OS X install—now 404s?

So if someone out there can find the owamp_time_fix.patch that was once hosted on that site then you would have something to work with. But now? No dice it seems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .